Bug 1756430 - Segmentation fault connecting to remote host
Summary: Segmentation fault connecting to remote host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: x2goclient
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1756983 1770437 1785809 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-27 15:36 UTC by Alessio
Modified: 2020-02-22 16:46 UTC (History)
4 users (show)

Fixed In Version: x2goclient-4.1.2.1-5.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-05 00:39:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Alessio 2019-09-27 15:36:13 UTC
Description of problem:

Core dump when connecting to a remote host, just after the connection seems established.

Version-Release number of selected component (if applicable):

x2goclient-4.1.2.1-4.fc31.x86_64

Actual results:

Segmentation fault (core dumped)
WARNING: failed to kill process group '26057': No such process


From journalctl

set 27 17:34:32 pbale kernel: x2goclient[26298]: segfault at 10 ip 00007f069fd41b16 sp 00007ffe14782a38 error 4 in libX11.so.6.3.0[7f069fd29000+8f000]
set 27 17:34:32 pbale kernel: Code: 00 00 00 00 f3 0f 1e fa 8b 87 e0 00 00 00 c3 0f 1f 44 00 00 f3 0f 1e fa 48 63 87 e0 00 00 00 48 c1 e0 07 48 03 87 e8 00 00 00 <48> 8b 40 10 c3 0f 1f 44 00 00 f3 0f 1e fa 48 63 f6 48 c1 e6 07 48


Expected results:


Additional info:

Comment 1 Michael Trip 2019-11-09 10:10:24 UTC
I have the same problem. When i run X2go on Gnome in X11 it runs fine though. It looks like a Wayland thing to me.

Comment 2 Michael Trip 2019-11-09 19:50:12 UTC
After googling a bit came across this article:

https://wiki.archlinux.org/index.php/X2Go#X2Go_client:_Cannot_connect_to_remote_X2Go_server_from_local_Wayland_session:_%22The_connection_with_the_remote_server_was_shut_down%22

I tried it and it worked. It involves changing the x2goclient.desktop file.

Comment 3 Matti Lehti 2019-12-13 18:06:35 UTC
Similar issue here when starting first time WinXP / Oracle Virtualbox VM in Wayland-session:
[ 8809.583633] VirtualBoxVM[8666]: segfault at 31 ip 00007f7a35acd670 sp 00007fff17f373f0 error 4 in libX11.so.6.3.0[7f7a35ab8000+8f000]
[ 8809.583639] Code: 64 48 8b 04 25 28 00 00 00 48 89 44 24 48 31 c0 48 8d 05 7b 98 08 00 48 85 f6 4c 0f 44 e0 48 8b 87 68 09 00 00 48 85 c0 74 02 <ff> 10 48 8d 4c 24 18 4c 8d 4c 24 14 44 89 ea 4c 89 e6 4c 8d 44 24

The VM started ok in Gnome X11 and after that starts also in Wayland.

Comment 4 Orion Poplawski 2019-12-14 03:47:55 UTC
Please see if https://bodhi.fedoraproject.org/updates/FEDORA-2019-097de371fc helps.

Comment 5 Fedora Update System 2019-12-16 01:10:25 UTC
x2goclient-4.1.2.1-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-097de371fc

Comment 6 Fedora Update System 2020-01-05 00:39:30 UTC
x2goclient-4.1.2.1-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Orion Poplawski 2020-02-22 16:43:38 UTC
*** Bug 1756983 has been marked as a duplicate of this bug. ***

Comment 8 Orion Poplawski 2020-02-22 16:45:42 UTC
*** Bug 1770437 has been marked as a duplicate of this bug. ***

Comment 9 Orion Poplawski 2020-02-22 16:46:16 UTC
*** Bug 1785809 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.