Description of problem:
Trying to install docker-ce (non modular package built for centos 7), some containerd.io dependency are excluded,
but there is no explanation why, what package it "conflicts" with, ...
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Add CentOS 7 docker repo to CentOS 8
cat > /etc/yum.repos.d/docker.repo <<'EOF'
2. Try to install docker-ce
# dnf install docker-ce
Last metadata expiration check: 0:01:01 ago on Fri Sep 27 13:17:19 2019.
Problem: package docker-ce-3:19.03.2-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
- cannot install the best candidate for the job
- package containerd.io-1.2.2-3.3.el7.x86_64 is excluded
- package containerd.io-1.2.2-3.el7.x86_64 is excluded
- package containerd.io-1.2.4-3.1.el7.x86_64 is excluded
- package containerd.io-1.2.5-3.1.el7.x86_64 is excluded
- package containerd.io-1.2.6-3.3.el7.x86_64 is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
containerd.io packages are excluded with a clear explanation
All the excluded packages provide "runc" but are built without modularity
runc is provided in the AppStream repo and built with modularity
The exclusion is expected modularity behavior I think, but better error messages are required here
Notes from https://bugzilla.redhat.com/show_bug.cgi?id=1734081
you can force docker-ce install by putting module_hotfixes=True in /etc/yum.repos.d/docker.repo, but as pointed by firstname.lastname@example.org, this is a dangerous override that can break your system
In this exact case if you try to install podman, it expects AppStream repo runc, not docker-ce repo runc version (included in containerd.io rpms)
*** Bug 1649754 has been marked as a duplicate of this bug. ***
I create a patch (https://github.com/rpm-software-management/libdnf/pull/840) that enhance the errors (see bellow). Please could you provide a feedback for the patch?
$ sudo dnf install --installroot /tmp/ddd meson --nogpgcheck --releasever=/ -x ninja-build-0:1.9.0-1.module_f30+2977+5b084e29.x86_64
Problem: conflicting requests
- package meson-0.50.0-1.module_f30+3586+7354b37a.noarch requires ninja-build, but none of the providers can be installed
- package meson-0.52.0-1.module_f30+6773+687c32a9.noarch requires ninja-build, but none of the providers can be installed
- package ninja-build-1.8.2-4.module_2059+c8879cb0.x86_64 is excluded by modular filtering
- package ninja-build-1.9.0-1.module_f30+2977+5b084e29.x86_64 is exclude by regular filtering
- package ninja-build-1.9.0-2.fc30.x86_64 is excluded by modular filtering
*** Bug 1741913 has been marked as a duplicate of this bug. ***
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.