Bug 1756567 - vte crashes due to out of bounds cursor
Summary: vte crashes due to out of bounds cursor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vte291
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FinalBlocker, FinalBlocker F31FinalFreezeException, FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-09-28 03:57 UTC by Evan Anderson
Modified: 2019-10-07 00:02 UTC (History)
5 users (show)

Fixed In Version: vte291-0.58.0-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-07 00:02:09 UTC


Attachments (Terms of Use)
test stimulus (41 bytes, text/plain)
2019-09-28 03:57 UTC, Evan Anderson
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/vte/issues/176 None None None 2019-10-04 03:51:39 UTC

Description Evan Anderson 2019-09-28 03:57:03 UTC
Created attachment 1620344 [details]
test stimulus

Description of problem:

Certain scrolling conditions in gnome terminal can cause VTE to crash due to out of bounds cursor position. More details in the gnome bug here: https://gitlab.gnome.org/GNOME/vte/issues/176 

Version-Release number of selected component (if applicable):

vte291-0.58.0-1.fc31.x86_64

How reproducible:

Frequently, depending on shell conditions. Easily reproducible when building Android, as the gnome bug documents.

Steps to Reproduce:
Reproduction steps in gnome bug
1. Open terminal with default 80x24 size
2. run "cat vte-176-crash.txt"

Actual results:

Gnome terminal crashes

Expected results:

Blank lines printed to screen

Additional info:

As noted in the Gnome bug, the fix is supplied by this commit: https://gitlab.gnome.org/GNOME/vte/commit/ef0734c1eb775cf98db9a6e8e87700830b1a3890. This change is scheduled for 0.58.1, which is in 2 weeks, and fairly close to the Fedora 31 freeze. I am filing this bug to ensure that the fix is tracked as this should probably be included in the final image.

Comment 1 Fedora Blocker Bugs Application 2019-10-04 03:54:25 UTC
Proposed as a Blocker for 31-final by Fedora user evana using the blocker tracking app because:

 Proposing as a blocker under the criteria "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." This issue is easily reproduced in certain workflows.

Comment 2 Adam Williamson 2019-10-04 14:21:38 UTC
I'd also cite Final criterion "All known bugs that can cause corruption of user data must be fixed or documented at Common F31 bugs" - the terminal app suddenly crashing could certainly cause you to lose data in anything running in that terminal app. I saw this yesterday, I think - at least, my gnome-terminal just suddenly up and crashed without warning or me doing anything in it in particular.

On the basis of both criteria I think I'm +1.

Comment 3 Fedora Update System 2019-10-04 14:43:08 UTC
FEDORA-2019-8288e417ac has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8288e417ac

Comment 4 Fedora Update System 2019-10-04 22:51:13 UTC
vte291-0.58.0-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8288e417ac

Comment 5 Fedora Update System 2019-10-07 00:02:09 UTC
vte291-0.58.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.