Bug 1756771 - f31 sugar fails to install
Summary: f31 sugar fails to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-09-29 21:16 UTC by satellitgo
Modified: 2019-10-03 23:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-03 23:23:03 UTC
Type: Bug


Attachments (Terms of Use)
log of ttemped dnf install of sugar in cinn terminal (44.43 KB, text/plain)
2019-09-29 21:16 UTC, satellitgo
no flags Details

Description satellitgo 2019-09-29 21:16:27 UTC
Created attachment 1620879 [details]
log of ttemped dnf install of sugar in cinn terminal

Description of problem:
sugar fails to install.

Version-Release number of selected component (if applicable):
Fedora-Everything-netinst-x86_64-31-20190928.n.0.iso

How reproducible:
when sugar-desktop selected

Steps to Reproduce:
1.
2.
3.

Actual results:
sugar fails to install but cinnamon does install
see attachment

Expected results:


Additional info:

Comment 1 satellitgo 2019-09-30 16:03:09 UTC
> Problem 2: conflicting requests
>  - nothing provides gstreamer-plugins-espeak needed by sugar-0.114-1.fc31.noarch

https://src.fedoraproject.org/rpms/gstreamer-plugins-espeak/commits/master
shows two days ago the gstreamer-plugins-espeak package was removed and then
re-added.  This seems a reasonable explanation for what you observed.

James Cameron
http://quozl.netrek.org/

Comment 2 Fedora Blocker Bugs Application 2019-09-30 16:06:15 UTC
Proposed as a Freeze Exception for 31-final by Fedora user satellit using the blocker tracking app because:

 non blocking spin

Comment 3 satellitgo 2019-09-30 23:26:01 UTC
https://kojipkgs.fedoraproject.org//work/tasks/1362/37971362/livemedia-out.log

2019-09-30 21:17:24,820 INFO pylorax: missing packages: gstreamer-plugins-espeak.

Comment 5 Adam Williamson 2019-09-30 23:31:43 UTC
hum, in fact it does seem like the most recent f31 package is not tagged f31 any more. I guess even though it was barely retired, it still needs an update submitted to go back in?

Comment 6 satellitgo 2019-09-30 23:59:04 UTC
https://pagure.io/releng/issue/8849

Comment 7 Geoffrey Marr 2019-10-01 00:54:02 UTC
Discussed during the 2019-09-30 blocker review meeting: [0]

The decision to delay the classification of this as a blocker bug was made as we believe this should be fixed in the next compose as the package has been unretired.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-30/f31-blocker-review.2019-09-30-16.00.txt

Comment 8 satellitgo 2019-10-03 17:37:33 UTC
f30 branched is not building soas   but f31 does...

Comment 9 Adam Williamson 2019-10-03 19:35:33 UTC
This should really be fixed now, as https://bodhi.fedoraproject.org/updates/FEDORA-2019-221c611ad9 was pushed stable. Next time we get a successful F31 compose, please check again, thanks!

Comment 12 Adam Williamson 2019-10-03 23:23:03 UTC
OK, let's close this then.


Note You need to log in before you can comment on or make changes to this bug.