Bug 175684 - enable 256 color support in xterm by default
Summary: enable 256 color support in xterm by default
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-13 23:12 UTC by dann
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 15:50:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dann 2005-12-13 23:12:12 UTC
Description of problem:

It would be nice if xterm was compiled with 256 color support by default. 

One of the reasons is that the next version of Emacs has very good support 
for 256 color terminals. That support enables the syntax coloring on such
terminals to look as good as it does on X11. 

To try this you can install Emacs from:
http://people.redhat.com/petersen/emacs

and in a 256 color enabled terminal run:

TERM=xterm-256color emacs -nw
then open a C file and look at the colors used for syntax highlighting.

Bug #130664 added an rpm build option to enable the 256 color support, but it
did not enable 256 color support by default.

Comment 1 Jason Vas Dias 2005-12-15 01:32:26 UTC
OK, xterm-207-8 in Rawhide is now compiled with 256-color support by default,
ie. by adding --enable-256-color to the configure.

Unless the upstream maintainer can think of any problems with enabling 256-color
support (I couldn't think of any), I'll enable it by default from now on. 

We'll see how that goes in Rawhide for a couple of weeks, and then I'll change
the FC-4 xterm to compile in 256-color support by default also.

BTW, terrific new emacs-22.0.50 version! I built it on FC-5 and it works great.

Comment 2 Fedora Update System 2005-12-21 23:05:26 UTC
From User-Agent: XML-RPC

xterm-207-2.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 3 Fedora Update System 2006-01-09 18:59:35 UTC
From User-Agent: XML-RPC

xterm-207-2.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.