Bug 1756936 - netcdf-devel depending on unavailable libsz.so.2()
Summary: netcdf-devel depending on unavailable libsz.so.2()
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: netcdf
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-30 09:08 UTC by Daniele Branchini
Modified: 2019-09-30 13:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-30 13:02:33 UTC


Attachments (Terms of Use)

Description Daniele Branchini 2019-09-30 09:08:12 UTC
Description of problem:
`netcdf-devel` seems to be present but it's impossible to install


Version-Release number of selected component (if applicable):

netcdf-4.7.0-2.el8.src.rpm
CentOS Linux release 8.0.1905 (Core) 


How reproducible:
```
# dnf install netcdf-devel
Last metadata expiration check: 1:18:21 ago on Mon Sep 30 09:45:37 2019.
Error: 
 Problem: conflicting requests
  - nothing provides libsz.so.2()(64bit) needed by netcdf-devel-4.7.0-2.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

```

Additional info:

according to https://pkgs.org/download/libsz.so.2()(64bit)
The libaec package for CentOs8  seems to be present in REMI repos. It was my understanding (at least on CentOs7) that REMI and EPEL shouldn't overlap.

It doesn't look like a bright idea, but: should I enable REMI repo to have `netcdf-devel` installed?

Comment 1 Orion Poplawski 2019-09-30 13:02:33 UTC
You need to enable the PowerTools repo - see https://fedoraproject.org/wiki/EPEL#Quickstart


Note You need to log in before you can comment on or make changes to this bug.