Bug 1756980 - Should use crun, not runc on Fedora 31 and onwards
Summary: Should use crun, not runc on Fedora 31 and onwards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: buildah
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Heon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-30 11:17 UTC by Debarshi Ray
Modified: 2019-10-03 00:36 UTC (History)
7 users (show)

Fixed In Version: buildah-1.11.2-3.git0bafbfe.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-03 00:36:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Debarshi Ray 2019-09-30 11:17:23 UTC
Buildah still uses runc, not crun, on Fedora >= 31.

Fedora >= 31 uses Cgroups v2, which runc doesn't support, so the OCI runtime should be switched to crun.

See:

$ rpm -q buildah
buildah-1.11.2-2.git0bafbfe.fc31.x86_64

$ rpm --requires -q buildah
containers-common
libassuan.so.0()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libdevmapper.so.1.02()(64bit)
libdevmapper.so.1.02(Base)(64bit)
libdevmapper.so.1.02(DM_1_02_97)(64bit)
libgpg-error.so.0()(64bit)
libgpgme.so.11()(64bit)
libgpgme.so.11(GPGME_1.0)(64bit)
libgpgme.so.11(GPGME_1.1)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.3.2)(64bit)
libseccomp.so.2()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
rtld(GNU_HASH)
runc >= 1.0.0-17

Compare that to podman:

$ rpm --requires -q podman
/bin/sh
config(podman) = 2:1.6.0-0.2.rc2.git9181c65.fc31
conmon
containernetworking-plugins >= 0.7.5-1
containers-common
crun >= 0.9.1-1
iptables
libassuan.so.0()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.28)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libgio-2.0.so.0()(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgpg-error.so.0()(64bit)
libgpgme.so.11()(64bit)
libgpgme.so.11(GPGME_1.0)(64bit)
libgpgme.so.11(GPGME_1.1)(64bit)
libostree-1.so.1()(64bit)
libostree-1.so.1(LIBOSTREE_2016.3)(64bit)
libostree-1.so.1(LIBOSTREE_2016.8)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.12)(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.3.2)(64bit)
librt.so.1()(64bit)
librt.so.1(GLIBC_2.2.5)(64bit)
libseccomp.so.2()(64bit)
libselinux.so.1()(64bit)
nftables
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
rtld(GNU_HASH)

Comment 1 Daniel Walsh 2019-10-01 11:33:56 UTC
Matt we need this fixed ASAP.  Do we need a new version of buildah released to grab this change?

Comment 2 Matthew Heon 2019-10-01 13:21:03 UTC
https://github.com/containers/buildah/blob/master/util/util.go#L254-L259

Already fixed, I think?

If that code is present in a release already, we're good; if not, we need a fresh Buildah release.

Comment 3 Tom Sweeney 2019-10-01 14:39:35 UTC
This went in with Buildah v1.11.0 and unless I'm mistaken, it looks like Podman v1.6.0 vendored in Buildah v.1.11.2 so we should be all set.

Comment 4 Debarshi Ray 2019-10-01 19:39:13 UTC
The problem is that the Fedora RPMs still requires runc, not crun.

I have now submitted a F32 build with the switch. If the change looks right, then I can submit one for F31 too.

Comment 5 Fedora Update System 2019-10-01 20:08:55 UTC
FEDORA-2019-b34fd3c00a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b34fd3c00a

Comment 6 Fedora Update System 2019-10-02 15:53:24 UTC
buildah-1.11.2-3.git0bafbfe.fc31, podman-1.6.0-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b34fd3c00a

Comment 7 Fedora Update System 2019-10-03 00:36:56 UTC
buildah-1.11.2-3.git0bafbfe.fc31, podman-1.6.0-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.