Bug 175710 - cupsd not reloaded after uninstall of gimp-print-cups
cupsd not reloaded after uninstall of gimp-print-cups
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gimp-print (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 04:31 EST by Robert van den Aker
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 12:04:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert van den Aker 2005-12-14 04:31:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
cupsd is not reloaded after uninstalling gimp-print-cups. Therefore /etc/cups/ppds.dat is not rebuilt and will contain stale entries. This will lead to errors when trying to add a printer that uses a PPD from gimp-print-cups.

Version-Release number of selected component (if applicable):
gimp-print-4.2.7-2

How reproducible:
Always

Steps to Reproduce:
1. Install gimp-print-cups
2. Use CUPS web interface to add printer; gimp-print PPD's are listed (as expected)
3. Uninstall gimp-print-cups
4. Use CUPS web interface to add printer; gimp-print PPD's are still listed (not as expected)

Additional info:

Rebuilding ppds.dat by reloading cupsd should occur in the following cases:

1. First install of gimp-print-cups
2. Upgrade of gimp-print-cups
3. (Final) uninstall of gimp-print-cups

Looking at the spec file for gimp-print, the following cases are covered:
(1) is covered by %post
(2) is covered by %postun
(3) is not covered

%postun has the conditional "if [ "$1" -ge "1" ]". I believe this bug can be fixed by removing that conditional (or changing it to "if [ "$1" -ge "0" ]", but that's a bit silly).

I'm setting severity for this bug to low because an easy workaround is present: manually reload cupsd after uninstalling gimp-print-cups.
Comment 1 Tim Waugh 2005-12-15 11:56:19 EST
Thanks for the report.  Yes, there is no need for the conditional in the %postun.

I have fixed in the devel branch (for Fedora Core / rawhide).
Comment 2 Tim Waugh 2005-12-15 12:04:23 EST
Since this issue has an easy work-around there will not be an update package for it.

Note You need to log in before you can comment on or make changes to this bug.