Bug 1757141 - [Kuryr] NPs for svc don't react to namespace labels updates
Summary: [Kuryr] NPs for svc don't react to namespace labels updates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Luis Tomas Bolivar
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On:
Blocks: 1757558
TreeView+ depends on / blocked
 
Reported: 2019-09-30 16:31 UTC by Luis Tomas Bolivar
Modified: 2020-05-13 21:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1757558 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:26:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 46 0 'None' 'closed' 'Bug 1757141: Ensure lb sg rules are updated upon namespace label updates' 2019-11-20 11:29:10 UTC
Launchpad 1845977 0 None None None 2019-09-30 16:31:17 UTC
OpenStack gerrit 685754 0 'None' 'MERGED' 'Ensure lb sg rules are updated upon namespace label updates' 2019-11-20 11:28:59 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-05-13 21:26:12 UTC

Description Luis Tomas Bolivar 2019-09-30 16:31:17 UTC
When there is a pod (and a svc) with a NP allowing access from a namespace with a give label, and another namespace label is updated to have the allowed label, the NP SG rules that are applied to the initial pod are updated to allow the updated namespace but not the rules on the loadbalancers, so the traffic does not go through.

Comment 2 Jon Uriarte 2019-10-03 16:17:55 UTC
Verified on an OCP 4.2 cluster (4.2.0-0.nightly-2019-10-02-001405) with Kuryr-controller image from OCP 4.3 (4.3.0-0.ci-2019-10-02-101344),
which includes the fix.
Verified that the fix does not add new regressions as well.

$ oc get pods -n openshift-kuryr kuryr-controller-5744b8d79d-wpdjl -o yaml | grep image
   image: registry.svc.ci.openshift.org/ocp/4.3-2019-10-02-101344@sha256:313a91b60fb5f49ece7e351ffee86e6f799b4399025d07cff9df8fec5adb5d06

It was not possible to verify on OCP 4.3 cluster as there are no nightly builds available at the moment.

Comment 5 Jon Uriarte 2019-10-18 08:08:58 UTC
Verified on OCP 4.3.0-0.nightly-2019-10-17-061631 build on top of OSP 13 2019-10-01.1 puddle.

release image: registry.svc.ci.openshift.org/ocp/release@sha256:2cafe25ec1ed2dfdec361cde13b4461d2a30194d0b41fbd1c6d3fad5ab34ca05

Related K8s NP upstream test -should allow ingress access from updated namespace- test passed.

Comment 7 errata-xmlrpc 2020-05-13 21:26:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.