Bug 1757243 - Cannot compose any HTML mail: 'invalid page ID'
Summary: Cannot compose any HTML mail: 'invalid page ID'
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1757763 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-30 23:05 UTC by Daniel Stone
Modified: 2019-10-03 05:16 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-30 23:22:09 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/evolution/issues/587 None None None 2019-10-01 06:38:52 UTC

Description Daniel Stone 2019-09-30 23:05:08 UTC
Description of problem:

I'm running Fedora Silverblue F30, up to date as of today.

Evolution cannot send any HTML mails it composes. The local view and composer are fine, but when trying to autosave, the UI notes:
'Could not save to autosave file “.evolution-composer.autosave-1G3X8Z”.
Error saving to autosave because “GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Invalid page ID: 37”.'

The journal notes:
Sep 30 18:57:24 strictly.fooishbar.org WebKitWebProces[29564]: Cannot obtain WebKitWebPage for 37
Sep 30 18:57:24 strictly.fooishbar.org evolution.bin[6009]: Failed to call a DBus Proxy method org.gnome.Evolution.WebExtension.EWebKitEditor.WC0x561146553ab0::ElementSetAttributeBySelector: Invalid page ID: 37



Version-Release number of selected component (if applicable): 3.32.4-1.fc30.x86_64



How reproducible: Every time



Steps to Reproduce:
1. Open Evolution
2. Compose an HTML mail
3. Wait for autosave to kick in, or try to send


Actual results: Failure, error messages


Expected results: I can actually send email


Additional info: This has been happening for a couple of weeks or so.

Comment 1 Daniel Stone 2019-09-30 23:22:09 UTC
Hadn't occurred to me that I'm actually running Evolution from a Flatpak now, not from Fedora. Brave new world!

Comment 2 Milan Crha 2019-10-01 06:38:52 UTC
Thanks for a bug report. The problem is due to WekKitGTK+, its 2.26.0 release causes it. It's fixed in upstream [1], and it'll be released with 3.34.1 version.

[1] https://gitlab.gnome.org/GNOME/evolution/issues/587

Comment 3 Milan Crha 2019-10-02 15:14:30 UTC
*** Bug 1757763 has been marked as a duplicate of this bug. ***

Comment 4 Benjamin Berg 2019-10-02 16:00:00 UTC
Is it maybe possible to backport the fix to F31? This is quite bad for me, and it could still be pushed out easily before the final freeze starts on 2019-10-08.

Comment 5 Milan Crha 2019-10-03 05:16:41 UTC
There's a 3.34.1 release on the next Monday. Try to run evolution as:

  $ WEBKIT_USE_SINGLE_WEB_PROCESS=1 evolution

It should help, at least partly/mostly.


Note You need to log in before you can comment on or make changes to this bug.