Bug 175730 - MOUNTD_NFS_V2=no doesn't work
MOUNTD_NFS_V2=no doesn't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks: RHEL3U8CanFix
  Show dependency treegraph
 
Reported: 2005-12-14 07:33 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0469
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 10:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nfs-mountd-v2-off-rhel3.patch (495 bytes, patch)
2005-12-14 07:33 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-12-14 07:33:01 EST
+++ This bug was initially created as a clone of Bug #175729 +++

As the mountd protocol version 1 and 2 handle NFS v2, both need to be switched
off to disable NFS v2.
Example:
mount -t nfs -o nfsvers=2 localhost:/test/ /mnt/test/
should fail with MOUNTD_NFS_V2=no in /etc/sysconfig/nfs ("mount to NFS server
'localhost' failed: server is down."), but doesn't without the attached patch.

-- Additional comment from bnocera@redhat.com on 2005-12-14 07:31 EST --
Created an attachment (id=122221)
nfs-mountd-v2-off-rhel4.patch
Comment 1 Bastien Nocera 2005-12-14 07:33:01 EST
Created attachment 122222 [details]
nfs-mountd-v2-off-rhel3.patch
Comment 3 Bob Johnson 2006-04-11 12:16:04 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.
Comment 4 Steve Dickson 2006-05-03 16:22:57 EDT
Fixed in nfs-utils-1.0.6-44EL 
Comment 8 Red Hat Bugzilla 2006-07-20 10:24:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0469.html

Note You need to log in before you can comment on or make changes to this bug.