Bug 1757424 - adjust build/image_ecosystem extended tests to account for kubectl/oc exec changes
Summary: adjust build/image_ecosystem extended tests to account for kubectl/oc exec ch...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Gabe Montero
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-01 13:35 UTC by Gabe Montero
Modified: 2020-05-13 21:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:26:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23891 'None' closed Bug 1757424: remove use of deprecated -p with kubectl/oc exec 2020-03-19 14:35:43 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-05-13 21:26:16 UTC

Description Gabe Montero 2019-10-01 13:35:36 UTC
We've started to see our `oc exec` usage fail:

TEP: calling the binary using 'oc exec /bin/bash -c'
Sep 30 19:51:29.334: INFO: Running 'oc --namespace=e2e-test-s2i-usage-sqdw7 --config=/tmp/configfile059334108 exec -p test-pod-37f3db13-2598-4b01-b8d6-3ddf6b4b2aba -- /bin/bash -c ruby --version'
Sep 30 19:51:29.429: INFO: Error running &{/usr/bin/oc [oc --namespace=e2e-test-s2i-usage-sqdw7 --config=/tmp/configfile059334108 exec -p test-pod-37f3db13-2598-4b01-b8d6-3ddf6b4b2aba -- /bin/bash -c ruby --version] []   Error: unknown shorthand flag: 'p' in -p

Corresponded with Sally O'Malley on forum-workloads and she confirmed that the -p option was deprecated upstream with 

https://github.com/kubernetes/kubernetes/commit/a59b4768054e7e2a1bf5f90499f3cd443af69a43

in particular https://github.com/openshift/kubernetes/blob/oc-4.3-kubernetes-1.16.0/staging/src/k8s.io/kubectl/pkg/cmd/exec/exec.go#L99-#L101

Need to switch to the form

oc exec podname -- /bin/bash -c ruby --version

Comment 1 Gabe Montero 2019-10-01 18:49:14 UTC
since it affects build e2e's as well changing component to that

Comment 2 Gabe Montero 2019-10-02 14:14:17 UTC
given this is e2e test only I'll move this to verified once it gets to on_qa

Comment 5 wewang 2019-10-09 06:24:48 UTC
Because the bug reflect e2e test, already passed in jobs in e2e

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/23891/pull-ci-openshift-origin-master-e2e-aws-builds/3100
  [Feature:Builds][Slow] s2i build with environment file in sources Building from a template should create a image from "test-env-build.json" template and run it in a pod [Suite:openshift]
  [Feature:Builds][Slow] incremental s2i build Building from a template should create a build from "incremental-auth-build.json" template and run it [Suite:openshift]

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/23891/pull-ci-openshift-origin-master-e2e-aws-image-ecosystem/479
[image_ecosystem][Slow] openshift images should be SCL enabled using the SCL in s2i images "centos/perl-524-centos7" should be SCL enabled [Suite:openshift]

Comment 7 errata-xmlrpc 2020-05-13 21:26:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.