Bug 175758 - system-config printer should use hplip for HP PSC devices
system-config printer should use hplip for HP PSC devices
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
: FutureFeature
Depends On:
Blocks: 175555
  Show dependency treegraph
 
Reported: 2005-12-14 12:40 EST by Tim Waugh
Modified: 2013-01-09 20:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 11:32:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-12-14 12:40:18 EST
+++ This bug was initially created as a clone of Bug #175555 +++
+++ comps still needs changing to include hplip +++

HP PSC devices require hplip to be installed and system-config-printer should
then prefer / only show the hplip way to get to this device, this way scanning
works too (out of the box). A problem is that hplip doesnot seem to get
installed by default, maybe system-config-printer should depend on this?

-- Additional comment from twaugh@redhat.com on 2005-12-13 04:54 EST --
I don't think that system-config-printer ought to depend on hplip, since there
are very many use-cases that don't require it and it is quite large.

We should add it to comps, though, wherever cups appears.

-- Additional comment from j.w.r.degoede@hhs.nl on 2005-12-13 06:42 EST --
Sounds reasonable, as long as it gets installed by default. Also
system-config-printer should use and if nescesarry enable hplip for PSC (all in
one) devices if installed. When using hplip one can just startup xsane and
everything works.

I can get it to work myself, but we want tobe as much plug and play as possbile,
right?


-- Additional comment from twaugh@redhat.com on 2005-12-13 09:33 EST --
That aspect is much harder to fix, as printconf-tui creates the queues that
kudzu/cups-config-daemon tell it to.

-- Additional comment from j.w.r.degoede@hhs.nl on 2005-12-14 02:54 EST --
Should I file a bug against kudzu for this then?

My mother in law has such a printer and I have converted here over to Linux, no
for other mother in law scenarios it would be nice if this would work 100% out
of the box, and all the parts are there.


-- Additional comment from twaugh@redhat.com on 2005-12-14 05:04 EST --
Yes please -- against hal I think.

-- Additional comment from jkeating@redhat.com on 2005-12-14 12:20 EST --
Assigning it to hal.
Comment 1 Tim Waugh 2005-12-14 12:41:19 EST
Reassigning back to jkeating.  We still need to add 'hplip' to comps wherever
'cups' appears.
Comment 2 Jesse Keating 2005-12-14 12:45:21 EST
hplip is already in comps under the printing id as a default.  Is there any
further work needed on this bug?
Comment 3 Hans de Goede 2005-12-14 15:35:15 EST
This may be relevant:
It wasn't installed on my system but thats FC3 -> FC5 test by yum yum and yum,
so no comps file involved.
Comment 4 Jesse Keating 2005-12-14 15:43:22 EST
(In reply to comment #3)
> This may be relevant:
> It wasn't installed on my system but thats FC3 -> FC5 test by yum yum and yum,
> so no comps file involved.
> 

Unfortunately this method isn't supported.  The package probably shouldn't be a
dep of cups itself as Tim states.  However since we are adding it into the
Printing group, a yum groupupdate or the like would pull it in.
Comment 5 Tim Waugh 2005-12-15 11:32:42 EST
Okay, no change needed then -- sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.