Bug 175766 - ICE compiling gnome-libs with -O1
ICE compiling gnome-libs with -O1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 14:53 EST by Bill Nottingham
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.1.0-0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-30 06:47:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source (107.70 KB, text/plain)
2005-12-14 14:53 EST, Bill Nottingham
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 25432 None None None Never

  None (edit)
Description Bill Nottingham 2005-12-14 14:53:06 EST
[root@js20-bc1-9 libart_lgpl]# gcc -v -DHAVE_CONFIG_H -I. -I. -I. -I. -I.
-DLIBART_COMPILATION -O1 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mminimal-toc
-I/usr/include/libpng10 -Wall -Wunused -c art_svp_wind.c -o art_svp_wind.o
-save-temps
gcc: warning: -pipe ignored because -save-temps specified
Using built-in specs.
Target: ppc64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--enable-checking=release --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-libgcj-multifile
--enable-languages=c,c++,objc,obj-c++,java,fortran --enable-java-awt=gtk
--disable-dssi --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre
--enable-secureplt --host=ppc64-redhat-linux
Thread model: posix
gcc version 4.1.0 20051212 (Red Hat 4.1.0-0.7)
 /usr/libexec/gcc/ppc64-redhat-linux/4.1.0/cc1 -E -quiet -v -I. -I. -I. -I. -I.
-I/usr/include/libpng10 -D__unix__ -D__gnu_linux__ -D__linux__ -Dunix -D__unix
-Dlinux -D__linux -Asystem=linux -Asystem=unix -Asystem=posix -DHAVE_CONFIG_H
-DLIBART_COMPILATION -D_FORTIFY_SOURCE=2 art_svp_wind.c -msecure-plt -m64
-mminimal-toc -Wall -Wall -Wunused -fexceptions -fstack-protector
-fworking-directory -O1 -fpch-preprocess -o art_svp_wind.i
ignoring nonexistent directory
"/usr/lib/gcc/ppc64-redhat-linux/4.1.0/../../../../ppc64-redhat-linux/include"
ignoring duplicate directory "."
ignoring duplicate directory "."
ignoring duplicate directory "."
ignoring duplicate directory "."
#include "..." search starts here:
#include <...> search starts here:
 .
 /usr/include/libpng10
 /usr/local/include
 /usr/lib/gcc/ppc64-redhat-linux/4.1.0/include
 /usr/include
End of search list.
 /usr/libexec/gcc/ppc64-redhat-linux/4.1.0/cc1 -fpreprocessed art_svp_wind.i
-msecure-plt -quiet -dumpbase art_svp_wind.c -m64 -mminimal-toc -auxbase-strip
art_svp_wind.o -g -O1 -Wall -Wall -Wunused -version -fexceptions
-fstack-protector --param ssp-buffer-size=4 -o art_svp_wind.s
GNU C version 4.1.0 20051212 (Red Hat 4.1.0-0.7) (ppc64-redhat-linux)
        compiled by GNU C version 4.1.0 20051212 (Red Hat 4.1.0-0.7).
GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: a491fbe37659985b5b0ecb5048cf5c79
art_svp_wind.c: In function ‘art_svp_uncross’:
art_svp_wind.c:1283: internal compiler error: in gen_add2_insn, at
optabs.c:4101Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccRnE6yi.out file, please attach this to
your bugreport.
Comment 1 Bill Nottingham 2005-12-14 14:53:07 EST
Created attachment 122243 [details]
preprocessed source
Comment 2 Bill Nottingham 2005-12-14 14:54:58 EST
I was compiling with -O1 to work around bug #175669.
Comment 3 Jakub Jelinek 2005-12-30 06:47:54 EST
This is fixed in 4.1.0-0.10 and later.

Note You need to log in before you can comment on or make changes to this bug.