Bug 175772 - svn help and man svn should mention /usr/share/doc/subversion-*/svn-book.html
svn help and man svn should mention /usr/share/doc/subversion-*/svn-book.html
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 15:38 EST by Jesse Glick
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 06:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Glick 2005-12-14 15:38:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The Subversion RPM for FC4 includes a local copy of the book "Version Control with Subversion", which furthermore looks to be built from the same source version as the actual code, and which is probably the best source of documentation on the tool. But the binary tool does not hint that it is there; you need to use rpm -ql subversion or the like to find it.

It is understandable that after downloading svn sources and building them yourself, the docs would not refer to anything beyond what is definitely included in those sources, plus public web sites. But the RPM has a predefined list of files in it, so FC could patch the svn sources a little bit before building to refer to the book which it will bundle, as a value-add.

Version-Release number of selected component (if applicable):
subversion-1.2.3-2.1

How reproducible:
Always

Steps to Reproduce:
1. Type svn help.

2. Type man svn.

3. Open an Info browser (e.g. C-h I in Emacs); search for "subversion" or "svn".

Actual Results:  After #1: you see

For additional information, see http://subversion.tigris.org/

which most usefully will link to

http://svnbook.red-bean.com/

if you follow that link. This covers Subversion 1.1, but 1.2.3 is installed.

After #2: you will see (edited down):

For more information [...] visit http://subversion.tigris.org.
Documentation for Subversion [...] can be found at http://svnbook.red-bean.com/.

Again, same links.

After #3: nothing, no matches.

Expected Results:  Both the help summary and the man page should have instructed you to open a web browser and enter the URL

file:///usr/share/doc/subversion-1.2.3/svn-book.html

which contains a complete, current local copy of the book. Info page probably unnecessary in this case.

Additional info:
Comment 1 Joe Orton 2005-12-15 07:51:12 EST
Since it looks like upstream have stopped packaging the book in the tarball it's
likely that the local copy of the docs will actually go away in the future
updates.  Will wait to see what happens with the final 1.3.0 tarball.
Comment 2 Joe Orton 2006-01-10 06:47:18 EST
Marking WONTFIX since upstream are indeed no longer bundling the book.

Note You need to log in before you can comment on or make changes to this bug.