Bug 175782 - Installing current nVidia drivers on RH Desktop 4
Installing current nVidia drivers on RH Desktop 4
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 17:19 EST by Tim Skirvin
Modified: 2013-03-06 00:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 16:51:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Skirvin 2005-12-14 17:19:18 EST
Description of problem:

The current nVidia video drivers are designed for the 2.6.11 kernel, and are not
stable on other systems.  We are experiencing stability issues, but the most con
crete information is just the warning that is emitted when the drivers are
installed...  

It would be very helpful if RedHat and nVidia could work together to offer full
support for the nVidia drivers. 

Version-Release number of selected component (if applicable):

nVidia drivers version 1.0-7676 and foward.  (Probably more.)


How reproducible: Every time.



Steps to Reproduce:
1. Install the nVidia drivers.  Get the warning.

  
Actual results:

The warnings we get when installing on RH Desktop 4 (2.6.9-22.0.1.EL) 

NVRM: loading NVIDIA Linux x86_64 NVIDIA Kernel Module  1.0-7676  Fri Jul 29    
13:15:16 PDT 2005                                                               
NVRM: WARNING: Your Linux kernel has problems in its implementation of          
NVRM: the change_page_attr kernel interface.  The NVIDIA kernel                 
NVRM: module will attempt to work around these problems, but                    
NVRM: system stability may be affected.  It is recommended that                 
NVRM: you update to a 2.6.11 or newer kernel.                     

Additional info: this happens on x86_64 and x86, and older versions of RH
Desktop as well.
Comment 1 Mike A. Harris 2005-12-14 21:47:54 EST
The problem described above appears to be an incompatibility between Nvidia's
kernel module and the shipping RHEL kernel.

Depending on the type of support contract you have with Red Hat, please
contact Red Hat support services via http://www.redhat.com/support
or at 1-888-RED-HAT1 for further assistance.

This is a bug in Nvidia's kernel module, which Nvidia will need to address
directly.  It is not a bug in Red Hat's kernel or X implementation, so
I'm setting status to "CANTFIX", as only Nvidia can fix their kernel
module to be compatible with the RHEL kernel.

Comment 2 Mike A. Harris 2005-12-14 21:50:19 EST
Also, changing component to 'kernel' as this issue is kernel related, not
X server related.
Comment 3 Tim Skirvin 2005-12-15 08:39:15 EST
It's somewhat an incompatibility, yes.  But to say "it's nVidia's problem, we're
ignoring it" is a premature response at best.  Getting graphic drivers that work
on modern systems is important for all users; it improves stability and
performance for any 3D application, be it a game, scientific software, or just a
random screen saver.

Basically, I'd like for you guys to offer some kind of choice.  Either offer a
2.6.11 kernel path, or work with nVidia to back-patch the required fixes into
2.6.9 so that their drivers will work.  It'll benefit both of your companies, in
the short and long terms.
Comment 4 Mike A. Harris 2005-12-15 08:44:14 EST
This is not a bug in Red Hat X, nor a bug in the Red Hat kernel.  It is a
bug in Nvidia's driver, and the proper way to handle that is to contact
Red Hat support and open up a proper support ticket.

Bugzilla is for tracking bugs in Red Hat software components, not for
bypassing our official support mechanisms.  Please use the correct
method for obtaining support.
Comment 5 Tim Skirvin 2005-12-15 08:51:08 EST
I've used both systems, actually.  I have been informed by multiple RedHat
employees and large customers at conferences and trade shows that the best way
to report a large-scale bug to RedHat is to both use the internal web ticketing
system *and* bugzilla.redhat.com.  

And yes, it is a bug in the 2.6.9 kernel that is causing nVidia to support only
2.6.11+, where the bug is fixed; the specific bug is listed in the error message
nVidia offers ("Your Linux kernel has problems in its implementation of          
the change_page_attr kernel interface").  
Comment 7 Mike A. Harris 2005-12-15 09:02:13 EST
I've reassigned this to the kernel component, so that our kernel maintainers
are aware of the issue you are reporting.  They will review the issue and
report back wether they consider this to be a Red Hat kernel bug or an
Nvidia kernel module problem.

Please update the bug report with the support ticket ID that you've filed
from the support system, and your TAM info for reference.

Thanks in advance.
Comment 8 Tim Skirvin 2005-12-15 09:38:09 EST
It's Service Request 768006.  And...TAM info?
Comment 9 Tim Skirvin 2005-12-19 09:54:43 EST
Seriously, what's TAM info?
Comment 10 Andy Mecham 2005-12-20 17:36:39 EST
This will not occur on 1.0-8174.  1.0-7676 assumed that all Linux kernels <
2.6.11 for the x86_64 platform were broken with regards to the
change_page_attr() interface.  A dynamic detection mechanism has since been
added.  If you need to stick with 1.0-7676, you can try passing NVreg_UseCPA=1
as a kernel module 
parameter.  This is a safe parameter to use on the 2.6.9-22.0.1.EL x86_64
kernel.  Please do _NOT_ use this parameter on kernels that do not contain the
change_page_attr() interface fixes.
Comment 11 Tim Skirvin 2005-12-20 17:51:01 EST
It looks like the 8174 patch won't solve our problems.  From our head video
developer:

  I've tested these drivers and they (NVidia) managed to break                  
  OpenGL shading language support pretty badly in that version.                   
  I'd probably recommend that we use a different rev that doesn't                 
  have these GLSL problems.  I'm hoping they'll have a new driver                 
  version posted in early January, otherwise we may want to pick                  
  one of the versions from November or so, which worked as I recall.   

I'll look into the NVreg_UseCPA option.           

Comment 12 Tim Skirvin 2006-01-13 10:34:11 EST
Again, while the updated drivers don't exercise the particular bug I complained
about above - the kernel issues - they still don't work with our systems, or for
anybody that's trying to use the OpenGL shading library.  To me, this means the
bug isn't fixed.

Comment 13 Lonni J Friedman 2006-01-13 10:37:18 EST
Tim,
Please generate an nvidia-bug-report.log from a system where you're experiencing
the problem with GLSL, along with instructions on how the problem can be reproduced.

Thanks,
Lonni
Comment 14 Tim Skirvin 2006-01-13 14:31:20 EST
http://www.nvnews.net/vbulletin/showthread.php?t=63109

It's the same problem, and John is one of my co-workers.
Comment 15 Lonni J Friedman 2006-01-13 14:58:06 EST
Tim,
I'm the same Lonni as in the thread you referenced, in which I've verified that
the GLSL bug will likely be resolved in the next driver release.  

John had the last post in that thread stating that he'd provide a "set of
scripts and test data" for me to test more thoroughly, so right now, it looks
like the action is on John, if additional testing/verification is desired.

Thanks,
Lonni
Comment 16 Jason Baron 2006-01-25 11:29:18 EST
Tim what kernel issues are you referring to in comment #12? thanks.
Comment 17 Tim Skirvin 2006-01-25 16:46:59 EST
Jason, see Comment #14.
Comment 18 Jason Baron 2006-01-25 16:51:17 EST
I don't see any evidence there of a Red Hat kernel bug (which is how this is
filed). Thus, i am closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.