Bug 17579 - Mesa glut.h redefines void exit(int)
Mesa glut.h redefines void exit(int)
Product: Red Hat Linux
Classification: Retired
Component: Mesa (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Depends On:
  Show dependency treegraph
Reported: 2000-09-17 20:17 EDT by roystgnr
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-09-17 20:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description roystgnr 2000-09-17 20:17:32 EDT
Using Mesa-devel-3.3-5 and glibc-devel-2.1.92-5, I get an error compiling
kdebase (from KDE 1.94):

g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include -I/usr/lib/qt2/include
-I/usr/X11R6/include  -I/usr/X11R6/include -UQT_NO_ASCII_CAST   -O2 -m486
-fno-strength-reduce -frtti -I/usr/X11R6/include -DQT_CLEAN_NAMESPACE
In file included from morph3d.cpp:65:
/usr/include/GL/glut.h:202: declaration of `void exit (int)' throws 
different exceptions
/usr/include/stdlib.h:577: than previous declaration `void exit (int) 
throw ()'

I haven't tried making a test case, but I'd be surprised if any program
including glut.h and stdlib.h didn't give the same error.  Commenting out
the definition in glut.h seemed to fix things.
Comment 1 Bernhard Rosenkraenzer 2000-09-23 11:21:10 EDT
Thanks for reporting this, fixed in 3.3-5.
Comment 2 Bernhard Rosenkraenzer 2000-09-23 11:28:57 EDT
Oops, make that 3.3-6

Note You need to log in before you can comment on or make changes to this bug.