Bug 175792 - at jobs have finite chance of failure
at jobs have finite chance of failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-14 19:51 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: at-3.1.8-49
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 11:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Generates shell delimiter more sensibly (591 bytes, patch)
2005-12-14 20:01 EST, JW
no flags Details | Diff

  None (edit)
Description JW 2005-12-14 19:51:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
For some reason a patch was added (at-3.1.8-SHELL-111386.patch) which introduces a finite possibility of a total 'at' job failure.

We all know that true randomness means that a random sequence like "aaaa" is equally likely as the sequence "xhgt".

So it is a reasonably possibility that the 'dd if=/dev/urandom ...' sequence generated by this patch produces characeters either all outside of the [:alnum:] set or that match, say, the word "echo" or perhaps "sh".


Version-Release number of selected component (if applicable):
at-3.1.8-77_FC4

How reproducible:
Always

Steps to Reproduce:
1.create an 'at' job and cross your fingers - you probably will be lucky.
2.
3.
  

Additional info:
Comment 1 JW 2005-12-14 20:01:03 EST
Created attachment 122258 [details]
Generates shell delimiter more sensibly

This patch generates a shell delimiter string at job creation time using simple
rand() rather than using dd/urandom/tr at job run time.  The dd/urandom/tr
method is flawed in that it introduces a greater possibility of a delimiter
being created that matches some content of the job.  This is because the length
of the generated delimiter will average 48 chars (200*(10+26+26)/256) but there
is a strong possibility that it will be, say, 10 characters.  This patch
guarantees the length of the delimiter is always 76 characters.
Comment 2 Jason Vas Dias 2005-12-15 12:40:37 EST
Yes, I'm planning to replace this "here document" method of executing at jobs
entirely in the next release - thanks for the patch.
Comment 3 Marcela Mašláňová 2006-08-22 11:25:17 EDT
It was patched in FC-4 version at-3.1.8-49.

Note You need to log in before you can comment on or make changes to this bug.