Bug 1757955 - clamav-0.102.2 is available
Summary: clamav-0.102.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clamav
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1796206 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-02 19:49 UTC by Upstream Release Monitoring
Modified: 2020-03-16 20:09 UTC (History)
15 users (show)

Fixed In Version: clamav-0.102.2-2.fc30 clamav-0.102.2-2.fc31 clamav-0.102.2-2.el8
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-19 01:28:05 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2019-10-02 19:49:58 UTC
Latest upstream release: 0.102.0
Current version/release in rawhide: 0.101.4-1.fc32
URL: http://www.clamav.net/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/291/

Comment 1 Upstream Release Monitoring 2019-10-02 19:50:12 UTC
The following Sources of the specfile are not valid URLs so we cannot automatically build the new version for you.  Please use URLs in your Source declarations if possible.

- clamav-0.102.0-norar.tar.xz
- main-58.cvd
- clamd-gen
- daily-25550.cvd
- bytecode-330.cvd
- clamd.sysconfig
- freshclam-sleep
- freshclam.sysconfig
- clamav-update.crond
- clamav-update.logrotate
- clamd.logrotate
- README.fedora
- clamav-milter.upstart
- clamav-milter.sysv
- clamav-milter.systemd
- clamd.scan.upstart
- clamd
- clamd-README
- clamd-wrapper
- clamd@.service
- clamd.SERVICE.init

Comment 2 Jason Tibbitts 2019-10-02 21:03:08 UTC
Note that the new on-access component has a hard dependency on libcurl >= 7.45, which means that EPEL6 and EPEL7 will have to build with --disable-clamonacc (and lose all support for on-access scanning).

Comment 3 Franky Van Liedekerke 2019-10-07 08:00:30 UTC
Please don't disable on-access scanning for EPEL7, that would greatly impact lots of customers. The solution seems to be the same as was being done in EPEL6 for zlib: include the libcurl sources and create a static lib, then build/link against that lib.

Comment 4 Upstream Release Monitoring 2019-11-20 22:48:06 UTC
Latest upstream release: 0.102.1
Current version/release in rawhide: 0.101.4-3.fc32
URL: http://www.clamav.net/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/291/

Comment 5 Upstream Release Monitoring 2019-11-20 22:48:16 UTC
The following Sources of the specfile are not valid URLs so we cannot automatically build the new version for you.  Please use URLs in your Source declarations if possible.

- clamav-0.102.1-norar.tar.xz
- main-58.cvd
- daily-25550.cvd
- bytecode-330.cvd
- clamd.sysconfig
- freshclam-sleep
- freshclam.sysconfig
- clamav-update.crond
- clamav-update.logrotate
- clamd.logrotate
- README.fedora
- clamav-milter.upstart
- clamav-milter.sysv
- clamav-milter.systemd
- clamd.scan.upstart
- clamd
- clamd-README
- clamd-wrapper
- clamd@.service
- clamd.SERVICE.init

Comment 6 Thomas Stephen Lee 2020-01-27 14:48:35 UTC
need for EPEL- 6/7/8 also 😊.

thanks.

Comment 7 Orion Poplawski 2020-01-27 15:34:27 UTC
Need is a strong word :).  I suspect we'll let this bake in Fedora for a while first.  And in fact we haven't even got this into rawhide yet due to various issues.

Comment 8 Sergio Basto 2020-01-27 16:05:38 UTC
 bodhi stopped to push update since Friday , as you can see [1], I'm trying fix very old bug reports like bug #801994 (opened in 2012) and others details and fixes , after push these fixes to epel 7 , I think we are ready to update clamav to 102 
that is my plan 

[1]
https://bodhi.fedoraproject.org/updates/FEDORA-2020-7e948a3067 
https://bodhi.fedoraproject.org/updates/FEDORA-2020-95898d6094

Comment 9 Thomas Stephen Lee 2020-01-27 22:57:37 UTC
we use many packages in EPEL(RHEL/CentOS) by rebuilding Fedora 31 SRPMS.

so will be happy to get the SRPM of test build on Fedora first .

we will test and give feedback.

thanks

Comment 10 Sergio Basto 2020-01-28 05:02:16 UTC
meanwhile clamav-0.101.5-7.fc31 available [1] we have to wait that bodhi starts to work again ... 

[1]
https://koji.fedoraproject.org/koji/buildinfo?buildID=1432994

Comment 11 Sergio Basto 2020-01-30 01:38:52 UTC
*** Bug 1796206 has been marked as a duplicate of this bug. ***

Comment 12 Sergio Basto 2020-01-30 01:45:11 UTC
 bodhi stopped to push updates since Friday 24 ,after clamav-0.101.5-7 tested , we move to 102.1

Comment 13 Thomas Stephen Lee 2020-01-30 04:46:44 UTC
Successfully rebuilt from srpm for CentOS/RHEL 7.
and using now.
no issues.

thanks.

Comment 14 Fedora Update System 2020-02-01 01:05:04 UTC
clamav-0.101.5-7.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb00a8235a

Comment 15 Fedora Update System 2020-02-09 01:03:55 UTC
clamav-0.101.5-7.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Harald Reindl 2020-02-09 02:51:15 UTC
"Fixed In Version: clamav-0.101.5-7.fc30" is a joke given that in my world 0.101 is smaller than 0.102

Comment 18 Fedora Update System 2020-02-10 03:35:16 UTC
FEDORA-2020-eb709b2d86 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-eb709b2d86

Comment 19 Fedora Update System 2020-02-10 03:35:45 UTC
FEDORA-EPEL-2020-5ef018f3f7 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-5ef018f3f7

Comment 20 Fedora Update System 2020-02-10 03:55:03 UTC
FEDORA-2020-a353378275 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a353378275

Comment 21 Fedora Update System 2020-02-11 00:31:35 UTC
clamav-0.102.2-2.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-5ef018f3f7

Comment 22 Amir Caspi 2020-02-11 00:36:51 UTC
Will this also be updated on EPEL 7?  Thanks!

Comment 23 Fedora Update System 2020-02-11 01:10:28 UTC
clamav-0.102.2-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-eb709b2d86

Comment 24 Fedora Update System 2020-02-11 01:24:40 UTC
clamav-0.102.2-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a353378275

Comment 25 Orion Poplawski 2020-02-15 22:19:22 UTC
(In reply to Amir Caspi from comment #22)
> Will this also be updated on EPEL 7?  Thanks!

Almost certainly.  But personally I'd like to see this bake a bit in Fedora first.

Comment 26 Fedora Update System 2020-02-19 01:28:05 UTC
clamav-0.102.2-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2020-02-19 01:53:07 UTC
clamav-0.102.2-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2020-02-25 01:46:05 UTC
clamav-0.102.2-2.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Amir Caspi 2020-03-16 20:08:33 UTC
(In reply to Orion Poplawski from comment #25)
> (In reply to Amir Caspi from comment #22)
> > Will this also be updated on EPEL 7?  Thanks!
> Almost certainly.  But personally I'd like to see this bake a bit in Fedora
> first.

Could I gently request that this get promoted to EPEL 7 now?  It's been a month and I haven't seen reports of major problems...
Thanks!

Comment 30 Amir Caspi 2020-03-16 20:09:55 UTC
Whoops.  Nevermind.  It looks like this was pushed recently but no comments put onto this bug.  Sorry for jumping the gun!


Note You need to log in before you can comment on or make changes to this bug.