Bug 17581 - up2date dependencies when not running gui
Summary: up2date dependencies when not running gui
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-18 00:45 UTC by Jerry Cloe
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 20:09:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:138 high SHIPPED_LIVE New, enhanced Update Agent for Red Hat Linux 6.x, 7.0 available 2000-12-21 05:00:00 UTC

Description Jerry Cloe 2000-09-18 00:45:22 UTC
When attempting to install up2date on a box that isn't running any gui 
installation fails due to dependencies.  Documentation suggests that 
up2date can be run completely as a command line tool (up2date -l and 
up2date -b).  The dependencies are all gui related.  The specific 
dependency failures I'm seeing are:

        pygnome is needed by up2date-1.13-1
        pygtk is needed by up2date-1.13-1
        rpm-python >= 3.0.4 is needed by up2date-1.13-1 (is this one gui 
related?)
        usermode >= 1.15 is needed by up2date-1.13-1

Can up2date be used in a non-gui environment?  If so, are these 
dependencies bogus in that situation?

Comment 1 Preston Brown 2000-12-21 19:28:34 UTC
fixed in errata being released shortly.  Yes, the new agent can be used in a
non-GUI environment.


Note You need to log in before you can comment on or make changes to this bug.