Bug 175817 - firstboot date module traces back
firstboot date module traces back
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-15 07:46 EST by Paul Nasrat
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 12:08:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2005-12-15 07:46:58 EST
Description of problem:

Install rawhide 20051215 (see my commits to get it to install)

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 494, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 77, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 55, in setupScreen
    self.dateWindow = mainWindow.mainWindow (firstboot = True, showPages =
["datetime", "ntp"])
TypeError: __init__() got an unexpected keyword argument 'showPages'


Version-Release number of selected component (if applicable):

firstboot-1.3.55-1.1
system-config-date-1.7.99.10-

How reproducible:

Always

Steps to Reproduce:
1.Install
2.reboot into firstboot
  
Actual results:

TRACEBACK

Expected results:

Shiny,fluffy date screen. 

Additional info:
Comment 1 Nils Philippsen 2005-12-15 08:25:29 EST
Hmm, this is from s-c-date-1.7.99.10/mainWindow.py:

[...]
class mainWindow:
    [...]
    def __init__(self, page=None, firstboot=False, showPages=None):
    [...]

Is it picking up the wrong (an old) mainWindow.py file?
Comment 2 Paul Nasrat 2005-12-15 08:44:22 EST
quite possibly due to the way firstboot modules/python path works.
Comment 3 Chris Lumens 2005-12-15 12:08:38 EST
I've seen this within the past couple days but am unable to reproduce.

Note You need to log in before you can comment on or make changes to this bug.