Bug 1758280 - Please build perl-Spreadsheet-ParseExcel for EPEL 8
Summary: Please build perl-Spreadsheet-ParseExcel for EPEL 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Spreadsheet-ParseExcel
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1759039 1759040 1759041 1759042 1759043 1759044
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-03 18:19 UTC by Robert Scheck
Modified: 2019-10-31 03:19 UTC (History)
4 users (show)

Fixed In Version: perl-Spreadsheet-ParseExcel-0.6500-24.1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-31 03:19:04 UTC


Attachments (Terms of Use)

Description Robert Scheck 2019-10-03 18:19:19 UTC
Description of problem:
Please build perl-Spreadsheet-ParseExcel for EPEL 8 (I need the package as run-time dependency for the perl-Spreadsheet-XLSX package).

Version-Release number of selected component (if applicable):
perl-Spreadsheet-ParseExcel-0.6500-24.fc31

Actual results:
No perl-Spreadsheet-ParseExcel in EPEL 8

Expected results:
perl-Spreadsheet-ParseExcel-0.6500-24.el8 or better ;-)

Additional info:
Please let me know if you are not interested in maintaining the package on EPEL 8 branch.

Comment 2 Jan Pazdziora 2019-10-04 13:18:39 UTC
I gave scratch build a try, it looks like we have quite a few unmatched dependencies:

DEBUG util.py:593:  No matching package to install: 'perl(Crypt::RC4)'
DEBUG util.py:593:  No matching package to install: 'perl(Digest::Perl::MD5)'
DEBUG util.py:593:  No matching package to install: 'perl(Jcode)'
DEBUG util.py:593:  No matching package to install: 'perl(OLE::Storage_Lite) >= 0.19'
DEBUG util.py:593:  No matching package to install: 'perl(Perl::MinimumVersion) >= 1.20'
DEBUG util.py:593:  No matching package to install: 'perl(Spreadsheet::WriteExcel)'
DEBUG util.py:593:  No matching package to install: 'perl(Test::MinimumVersion) >= 0.008'
DEBUG util.py:593:  No matching package to install: 'perl(Unicode::Map)'

https://kojipkgs.fedoraproject.org//work/tasks/175/38050175/root.log

Comment 3 Jan Pazdziora 2019-10-07 09:50:56 UTC
I've filed bugzilla asking for the dependencies to be added to EPEL.

The perl-Perl-MinimumVersion-1.38-20.el8 is already in EPEL 8 testing.

Comment 4 Jan Pazdziora 2019-10-07 09:51:06 UTC
I've filed bugzillas asking for the dependencies to be added to EPEL.

The perl-Perl-MinimumVersion-1.38-20.el8 is already in EPEL 8 testing.

Comment 5 Fedora Update System 2019-10-16 11:19:47 UTC
FEDORA-EPEL-2019-b912a36fe9 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-b912a36fe9

Comment 6 Fedora Update System 2019-10-16 17:30:48 UTC
perl-Spreadsheet-ParseExcel-0.6500-24.1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-b912a36fe9

Comment 7 Fedora Update System 2019-10-31 03:19:04 UTC
perl-Spreadsheet-ParseExcel-0.6500-24.1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.