Bug 1758396 - QT5 application do not draw decorations when qgnomeplatform is installed
Summary: QT5 application do not draw decorations when qgnomeplatform is installed
Keywords:
Status: CLOSED DUPLICATE of bug 1756024
Alias: None
Product: Fedora
Classification: Fedora
Component: qgnomeplatform
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-04 02:59 UTC by Leon Lagodny
Modified: 2019-10-04 05:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-04 05:28:44 UTC


Attachments (Terms of Use)
keepassxc with qnomeplatform installed (1.38 MB, image/png)
2019-10-04 02:59 UTC, Leon Lagodny
no flags Details
keepassxc without qnomeplatform installed (1.39 MB, image/png)
2019-10-04 03:04 UTC, Leon Lagodny
no flags Details

Description Leon Lagodny 2019-10-04 02:59:55 UTC
Created attachment 1622467 [details]
keepassxc with qnomeplatform installed

Description of problem:
QT5 application do not draw decorations when qgnomeplatform is installed.
When it is removed they fall back to the default theme and start drawing them again.

Version-Release number of selected component (if applicable):
31

How reproducible:
100%

Steps to Reproduce:
1. Start any QT5 application
2. Observe them not drawing window decorations

Additional info:
This only started to happen very recently. A workaround is to just remove
qgnomeplatform and live with the white default theme. KeepassXC prints the following message:
`Could not create decoration from factory! Running with no decorations.`

Comment 1 Leon Lagodny 2019-10-04 03:04:32 UTC
Created attachment 1622468 [details]
keepassxc without qnomeplatform installed

Comment 2 Jan Grulich 2019-10-04 05:28:44 UTC
Should be fixed with latest QGnomePlatform update, which is qgnomeplatform-0.5-17.fc31.

*** This bug has been marked as a duplicate of bug 1756024 ***


Note You need to log in before you can comment on or make changes to this bug.