Bug 1758411 - Qt5 applications no longer have window decorations
Summary: Qt5 applications no longer have window decorations
Keywords:
Status: CLOSED DUPLICATE of bug 1756024
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwayland
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-04 04:59 UTC by Dima Ryazanov
Modified: 2019-10-04 05:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-04 05:28:55 UTC


Attachments (Terms of Use)

Description Dima Ryazanov 2019-10-04 04:59:33 UTC
Description of problem:
After installing today's updates - in particular, Qt5 - I tried running Qt5 examples, and saw that they're all missing window decorations.

Version-Release number of selected component (if applicable):
qt5-qtwayland-5.12.5-1.fc31.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Run /usr/lib64/qt5/examples/widgets/richtext/textedit/textedit (or any other example)
2.
3.

Actual results:
The window is missing decorations. There is an error message in the output:
"Could not create decoration from factory! Running with no decorations."

Expected results:
The window should display decorations.

Additional info:
Using Gnome 3.34.0

Comment 1 Jan Grulich 2019-10-04 05:28:55 UTC
Should be fixed with latest QGnomePlatform update, which is qgnomeplatform-0.5-17.fc31.

*** This bug has been marked as a duplicate of bug 1756024 ***


Note You need to log in before you can comment on or make changes to this bug.