Bug 1758434 - Could not specify Statefulset.emptyDir.sizeLimit
Summary: Could not specify Statefulset.emptyDir.sizeLimit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Ryan Phillips
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-04 06:59 UTC by mchoma
Modified: 2020-05-13 21:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Cause: The LocalStorageCapacityIsolation feature was disabled in a previous version. Consequence: The use could not set the `Statefulset.emptyDir.sizeLimit` parameter. Fix: The LocalStorageCapacityIsolation feature was re-enabled. Result: The user can set the `Statefulset.emptyDir.sizeLimit` parameter.
Clone Of:
Environment:
Last Closed: 2020-05-13 21:26:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 462 0 None closed Bug 1758434: re-enable LocalStorageCapacityIsolation 2020-11-03 14:37:42 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-05-13 21:26:46 UTC

Description mchoma 2019-10-04 06:59:54 UTC
Version-Release number of selected component (if applicable):
3.11
4.1

Steps to Reproduce:
1. Create SS with emptyDir.sizeLimit

ss.yaml:
apiVersion: v1
kind: Service
metadata:
  name: nginx
  labels:
    app: nginx
spec:
  ports:
    - port: 80
      name: web
  clusterIP: None
  selector:
    app: nginx
---
apiVersion: apps/v1
kind: StatefulSet
metadata:
  name: web
spec:
  serviceName: "nginx"
  replicas: 2
  selector:
    matchLabels:
      app: nginx
  template:
    metadata:
      labels:
        app: nginx
    spec:
      containers:
        - name: nginx
          image: k8s.gcr.io/nginx-slim:0.8
          ports:
            - containerPort: 80
              name: web
          volumeMounts:
            - name: www
              mountPath: /usr/share/nginx/html
      volumes:
        - emptyDir:
            medium: Memory
            sizeLimit: 1Mi

2. oc apply -f ss.yaml
3. oc get statefulset/web -o yaml --export | grep sizeLimit
sizeLimit is not persisted
4. when I edit from GUI I get "No changes were applied to stateful set web.Make sure any new fields you may have added are supported API fields."

Comment 1 mchoma 2019-10-04 07:06:38 UTC
sizeLimit is mentioned in doc I can see sizeLimit mentioned in doc https://docs.openshift.com/container-platform/3.11/rest_api/apis-apps/v1beta1.StatefulSet.html#object-schema

Comment 3 Michal Fojtik 2019-10-09 10:53:28 UTC
This option only works if the LocalStorageCapacityIsolation feature is turned on.

Comment 5 Ryan Phillips 2019-10-09 13:56:17 UTC
We can re-enable this feature. I have opened a pull request to do that with this BZ.

Comment 9 errata-xmlrpc 2020-05-13 21:26:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.