Bug 1758682 - No automated test job verifies disruption in PRs or as release informing
Summary: No automated test job verifies disruption in PRs or as release informing
Keywords:
Status: CLOSED DUPLICATE of bug 1837157
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Clayton Coleman
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1758606
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-04 20:11 UTC by Clayton Coleman
Modified: 2020-05-20 14:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1758606
Environment:
Last Closed: 2020-05-20 14:29:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 23877 0 None closed Bug 1758682: Make the quorum restore disruptive test to be resilient and add disruptive suite 2020-05-26 23:43:28 UTC

Description Clayton Coleman 2019-10-04 20:11:39 UTC
+++ This bug was initially created as a clone of Bug #1758606 +++

Description of problem:

We currently do not comprehensively run a set of disruptive tests against the latest code in any of our branches or against PRs that fits our general pattern for testing.

Expected results:

We should have a test suite "disruptive" as part of openshift-tests that emulates the recovery flow that we document for customers. That previously existed as bash script testing, but should be part of openshift-tests.

We should have an e2e-aws-disruptive test that runs as part of some PRs (installer, machine-config, etcd, origin) and also runs as part of release-informing for 4.3, 4.2, and 4.1. At the end of the test we will reverify the functionality of the cluster.

That suite will in the future add other disruptive events that the cluster must recover from.


Additional info:

Backporting so 4.2 jobs work.
Verification of this needs to happen by a release architect assessing the CI jobs.

--- Additional comment from Clayton Coleman on 2019-10-04 11:30:25 EDT ---

Assigned to etcd because that's the first disruptive test (recovery of etcd) that will be in the suite.

--- Additional comment from errata-xmlrpc on 2019-10-04 14:26:33 EDT ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2019:46256-02
https://errata.devel.redhat.com/advisory/46256

Comment 2 ge liu 2019-10-30 07:07:45 UTC
@jforrest, pls help to confirm if the job is ready for 4.2, I can't find it. thanks in advance!


Note You need to log in before you can comment on or make changes to this bug.