Bug 175869 - kernel "make xconfig" and "make gconfig" will not complete
kernel "make xconfig" and "make gconfig" will not complete
Status: CLOSED DUPLICATE of bug 170658
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-12-15 16:03 EST by Need Real Name
Modified: 2013-03-06 00:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-31 15:50:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
List of rpm's installed. (17.05 KB, text/plain)
2005-12-16 08:47 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-12-15 16:03:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
Make xconfig and make gconfig will not complete when trying to configure or a kernel recompile.  This is from a standard install of ES 4.0 for x86_64.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install rh EP 4.0 x86_64
2. Install kernel source
3. rpmbuild --bp --target=x86_64 kernel-2.6.spec
4. use either make xconfig or make gconfig

Actual Results:  make xconfig stops with:
$ make xconfig
  HOSTCC  -fPIC scripts/kconfig/zconf.tab.o
  HOSTLLD -shared scripts/kconfig/libkconfig.so
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/kconfig_load.o
  HOSTCC  scripts/kconfig/mconf.o
  HOSTCXX scripts/kconfig/qconf.o
  HOSTLD  scripts/kconfig/qconf
/usr/bin/ld: cannot find -lqt
collect2: ld returned 1 exit status
make[1]: *** [scripts/kconfig/qconf] Error 1
make: *** [xconfig] Error 2

and make gconfig stops with:

make gconfig
* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
make[1]: *** [scripts/kconfig/.tmp_gtkcheck] Error 1
make: *** [gconfig] Error 2

Expected Results:  the kernel xconfig or gconfig tool should start

Additional info:
Comment 1 Pete Zaitcev 2005-12-15 16:20:36 EST
I don't see a problem. Install needed packages.
Comment 2 Need Real Name 2005-12-16 08:46:58 EST
What am I maissing?

The following qt libraries are installed:


see also attached complete list.
Comment 3 Need Real Name 2005-12-16 08:47:50 EST
Created attachment 122319 [details]
List of rpm's installed.
Comment 4 Jukka Ketelaars 2006-02-25 08:38:07 EST
Regarding gconfig: you are missing libglade2-devel
Comment 5 Jason Baron 2006-05-31 15:50:59 EDT

*** This bug has been marked as a duplicate of 170658 ***
Comment 6 Jay Turner 2007-02-08 08:20:05 EST
Carrying over acks from 170658.

Note You need to log in before you can comment on or make changes to this bug.