Bug 1758724 - VirtualBox is broken in wayland
Summary: VirtualBox is broken in wayland
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1780888 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-05 02:30 UTC by Basil Eric Rabi
Modified: 2019-12-09 09:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-05 15:29:39 UTC


Attachments (Terms of Use)
backtrace using gdb (55.75 KB, text/plain)
2019-10-05 02:30 UTC, Basil Eric Rabi
no flags Details

Description Basil Eric Rabi 2019-10-05 02:30:20 UTC
Created attachment 1622646 [details]
backtrace using gdb

Description of problem:
In f30, VirtualBox runs fine in wayland session but now broken in f31.

How reproducible:
Always

Steps to Reproduce:
1. GDK_BACKEND=X11 virtualbox

Actual results:
Qt WARNING: QSocketNotifier: Can only be used with threads started with QThread

(VirtualBox:9669): Gtk-WARNING **: 09:59:44.498: cannot open display: :0

Expected results:
VirtualBox runs.

Comment 1 Jonas Ådahl 2019-10-05 15:29:39 UTC
This is a problem with VirtualBox, not gnome-shell. VirtualBox uses Qt, but has hard coded dependencies on X11 API, without forcing the Qt's backend to be the one it depends on.

A work aronud is: QT_QPA_PLATFORM=xcb virtualbox

VirtualBox is not a Fedora package, but an rpmfusion package. Seems to be a bug open about it already: https://bugzilla.rpmfusion.org/show_bug.cgi?id=5383

Marking as CANTFIX as it's not something gnome-shell can fix, and I cannot move it anywhere on this bug tracker.

Comment 2 Sergio Monteiro Basto 2019-10-06 23:59:03 UTC
(In reply to Jonas Ådahl from comment #1)

But why we don't have this problem on F30 and F29 ?

Comment 3 Jonas Ådahl 2019-10-07 09:53:17 UTC
Because Qt defaults to the Wayland backend in F31, while in F29 and F30 it always used X11, meaning on always going via Xwayland.

Comment 4 Nadav Har'El 2019-12-09 09:09:40 UTC
*** Bug 1780888 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.