Bug 1758744 - Not respecting "openshift_pkg_version" when running 3.10 -> 3.11 upgrade
Summary: Not respecting "openshift_pkg_version" when running 3.10 -> 3.11 upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.11.z
Assignee: Russell Teague
QA Contact: liujia
URL:
Whiteboard:
: 1771622 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-05 08:37 UTC by Abhishek
Modified: 2019-11-25 13:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
During an upgrade with openshift_pkg_version specified the latest available version was being installed. The openshift-clients package was being upgraded during an unrelated master upgrade step. Due to package dependencies, this resulted in all dependent openshift packages being updated to the latest version. This change removes the openshift_cli role as the clients are installed and upgraded as part of the openshift_node role. The upgrade of the client binaries on Atomic Host were moved to the openshift_node role for consistency.
Clone Of:
Environment:
Last Closed: 2019-11-18 14:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 11956 0 'None' closed Bug 1758744: Fix upgrade not respecting openshift_pkg_version 2021-01-26 06:02:52 UTC
Red Hat Knowledge Base (Solution) 4590941 0 None None None 2019-11-15 17:02:50 UTC
Red Hat Product Errata RHBA-2019:3817 0 None None None 2019-11-18 14:52:21 UTC

Description Abhishek 2019-10-05 08:37:49 UTC
Description of problem: When running the upgrade from 3.10 to 3.11 it's upgrading the node package to the latest errata irrespective of the `openshift_pkg_version` parameter defined in the Ansible host file.

openshift_pkg_version=-3.11.129
openshift_image_tag=v3.11.129

# rpm -qa | grep openshift-ansible
openshift-ansible-docs-3.11.146-1.git.0.fcedb45.el7.noarch
openshift-ansible-3.11.146-1.git.0.fcedb45.el7.noarch
openshift-ansible-roles-3.11.146-1.git.0.fcedb45.el7.noarch
openshift-ansible-playbooks-3.11.146-1.git.0.fcedb45.el7.noarch

After upgrade:

# rpm -qa | grep atomic-openshift-node
atomic-openshift-node-3.11.146-1.git.0.4aab273.el7.x86_64

Comment 1 Scott Dodson 2019-10-14 20:06:26 UTC
Please provide complete inventory, ansible version, and logs from the upgrade that exhibited unexpected behavior. Without that we'll have to close this insufficient data.

Comment 3 liujia 2019-10-16 07:25:08 UTC
should be a known issue at https://bugzilla.redhat.com/show_bug.cgi?id=1721406

Comment 7 errata-xmlrpc 2019-11-18 14:52:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3817

Comment 8 Russell Teague 2019-11-25 13:30:16 UTC
*** Bug 1771622 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.