Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1758759 - katello-certs-check must set LC_TIME for $(date) commands
Summary: katello-certs-check must set LC_TIME for $(date) commands
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Certificates
Version: 6.5.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Omkar Khatavkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-05 12:29 UTC by Andreas Bleischwitz
Modified: 2024-02-28 20:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-18 01:30:13 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Fix for missing LC_TIME environment (998 bytes, patch)
2019-10-05 12:29 UTC, Andreas Bleischwitz
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 28004 0 Normal New katello-certs-check should set locales for $(date) commands 2020-11-17 19:07:49 UTC

Description Andreas Bleischwitz 2019-10-05 12:29:41 UTC
Created attachment 1622733 [details]
Fix for missing LC_TIME environment

Description of problem:
When invoking katello-certs-check with LC_TIME set to anything else than "C" or "en_US", the comparison of dates will fail.

Version-Release number of selected component (if applicable):
# rpm -qf /usr/sbin/katello-certs-check 
foreman-installer-katello-3.10.0.8-1.el7sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. export LC_TIME to i.e. "de_DE.utf8"
2. invoke 'katello-certs-check' with valid certs and keys
3.

Actual results:
"""
Checking server certificate encoding: 
[OK]

date: ungültiges Datum „Okt 5 12:08:34 2019“
Checking expiration of certificate: /usr/sbin/katello-certs-check: Zeile 94: [: -gt: Einstelliger (unärer) Operator erwartet.

[OK]

Checking expiration of CA bundle: /usr/sbin/katello-certs-check: Zeile 100: [: -gt: Einstelliger (unärer) Operator erwartet.

[OK]
"""

Expected results:
"""
Checking server certificate encoding: 
[OK]

Checking expiration of certificate: 
[OK]

Checking expiration of CA bundle: 
[OK]
"""

Additional info:

Comment 3 Eric Helms 2020-11-18 01:30:13 UTC
I attempted to test this myself and have not been able to reproduce it. Perhaps there are other factors involved with the system's configuration:

Checking expiration of certificate: de_DE.utf8
[OK]


Given this works for me against latest Satellite 6.8 I am going to opt to close current release. If you are able to reproduce on the latest release and can provide more details on if there is language differences involved with the generated certificates or how the locale is set on the system.


Note You need to log in before you can comment on or make changes to this bug.