Bug 1758851 - epel-8-x86_64: cannot install the best candidate for the job: package is excluded
Summary: epel-8-x86_64: cannot install the best candidate for the job: package is excl...
Keywords:
Status: CLOSED DUPLICATE of bug 1756681
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: perl-generators
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: perl-maint-list
QA Contact: RHEL Stacks Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-06 08:46 UTC by marketplace
Modified: 2019-10-07 06:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-07 06:59:28 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description marketplace 2019-10-06 08:46:19 UTC
Greetings!
When build package in epel-8-x86_64 repository, an error constantly appears and the build stop:

ERROR: Command failed: 
 # /usr/bin/dnf builddep --installroot /var/lib/mock/1048899-epel-8-x86_64-1570349816.757426/root/ --releasever 8 --setopt=deltarpm=False --allowerasing --disableplugin=local --disableplugin=spacewalk --disableplugin=local --disableplugin=spacewalk /var/lib/mock/1048899-epel-8-x86_64-1570349816.757426/root//builddir/build/SRPMS/nginx-1.17.4-100.el8.src.rpm --setopt=tsflags=nocontexts
No matches found for the following disable plugin patterns: local, spacewalk
Copr repository                                  41 kB/s | 3.3 kB     00:00    
Additional repo copr_marketplace_sscg            46 kB/s | 3.3 kB     00:00    
Additional repo copr_marketplace_gperftools      38 kB/s | 3.3 kB     00:00    
Package gcc-8.2.1-3.5.el8.x86_64 is already installed.
Package systemd-239-13.el8_0.5.x86_64 is already installed.
Error: 
 Problem: cannot install the best candidate for the job
  - package perl-generators-1.10-7.module_el8.0.0+50+c3b345cd.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Logs:
https://copr-be.cloud.fedoraproject.org/results/marketplace/nginx/epel-8-x86_64/01048899-nginx/builder-live.log.gz

https://copr-be.cloud.fedoraproject.org/results/marketplace/gperftools/epel-8-x86_64/01048793-gperftools/builder-live.log.gz

Comment 1 Pavel Raiskup 2019-10-06 11:20:31 UTC
I'm not sure what to do about this in copr/mock, we don't maintain perl in copr-team.
Flipping against RHEL 8 component.

Comment 2 Pavel Raiskup 2019-10-06 12:27:48 UTC
Reproducible with 'autoconf-2.69-27.el8.src.rpm' rebuild, with
released rhel 8 chroots (config from mock-core-configs):
$ mock -r rhel-8-x86_64 --rebuild autoconf-2.69-27.el8.src.rpm

Comment 3 marketplace 2019-10-06 16:49:36 UTC
I tried to build perl-generators package itself.

Error:
Last metadata expiration check: 0:00:03 ago on Sun 06 Oct 2019 12:59:49 PM UTC.
Package coreutils-8.30-6.el8.x86_64 is already installed.
Package make-1:4.2.1-9.el8.x86_64 is already installed.
Package sed-4.5-1.el8.x86_64 is already installed.
Error: 
 Problem 1: cannot install the best candidate for the job
  - package perl-Fedora-VSP-0.001-9.module_el8.0.0+50+c3b345cd.noarch is excluded
 Problem 2: cannot install the best candidate for the job
  - package perl-generators-1.10-7.module_el8.0.0+50+c3b345cd.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Logs:
https://copr-be.cloud.fedoraproject.org/results/marketplace/perl-generators/epel-8-x86_64/01049012-perl-generators/builder-live.log.gz

Comment 4 Stephen John Smoogen 2019-10-06 20:13:33 UTC
The problem looks to be in the mock configurations. The EPEL-8 uses best=1 which ends up getting I think is confused with the 'pseudo' modules that perl and some other items are. [perl-generators-1.10-7.module_el8.0.0+50+c3b345cd.noarch is actually with perl-5.24 module while ./AppStream/x86_64/kickstart/Packages/perl-generators-1.10-7.el8.noarch.rpm looks like it isn't a module but is inside the 5.26 module. ]

Comment 5 Miroslav Suchý 2019-10-07 06:59:28 UTC

*** This bug has been marked as a duplicate of bug 1756681 ***


Note You need to log in before you can comment on or make changes to this bug.