Bug 175891 - phpLDAPAdmin and SELinux
Summary: phpLDAPAdmin and SELinux
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: phpldapadmin   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dmitry Butskoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-15 23:29 UTC by Ignacio Vazquez-Abrams
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 19:15:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ignacio Vazquez-Abrams 2005-12-15 23:29:51 UTC
phpldapadmin installs into /usr/share, which httpd is not allowed to read if
SELinux is enforcing. Recommend installation into /var/www/phpldapadmin instead.

Comment 1 Dmitry Butskoy 2005-12-16 12:12:59 UTC
The files layout of phpldapadmin was derived from the similar php package
"squirrelmail" (Fedora Core). Squirrelmail places its files under /usr/share .
I've considered it as a precedent.

As I see now, both FC4 and devel "squirrelmail"s still have files under /usr/share. 

Are there any SELinux-related issues with the squirrelmail package? Why this
(approximately) similar Fedora Core's package still have the stuff under
/usr/share ? Perhaps there is some another way to fix SELinux related issues here?

Saying this, I don't ignore this bug report, I just want to make fixes the
similar way like it is made in Fedora Core...

Comment 2 Ignacio Vazquez-Abrams 2005-12-16 19:15:26 UTC
No, you're right, looks like it was a problem with the file contexts differing
from the normal policy. Sorry, closing.


Note You need to log in before you can comment on or make changes to this bug.