Bug 175904 - GCC4 Segmentation fault - rpmbuild of glibc
Summary: GCC4 Segmentation fault - rpmbuild of glibc
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://rafb.net/paste/results/FMa01I9...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-16 02:54 UTC by Jasper O. Hartline
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-12-16 13:57:38 UTC


Attachments (Terms of Use)

Description Jasper O. Hartline 2005-12-16 02:54:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
GCC4 dies from a Internal Compiler Error during rpmbuild of glibc.
The GCC4 version is stated already in this bug report.

Using       Kernel-2.6.14-1.1653_FC4
Compiling   glibc-2.3.5-10.3.src.rpm
Using       rpm-build-4.4.1-22

This is the jist of the error I recieve:
----------------------- Make Error Below ------------------------------------
nis_hash.c: In function '__nis_hash':
nis_hash.c:76: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [/usr/src/redhat/BUILD/glibc-20050524T1606/build-i386-linux/nis/nis_hash.op] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/glibc-20050524T1606/nis'
make[1]: *** [nis/subdir_lib] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/glibc-20050524T1606'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.52337 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.52337 (%build)
---------------------------- End of Error Section ----------------------------


Hopefully we can determine what and why it fouled up.
Thank you.
J. Hartline

Version-Release number of selected component (if applicable):
gcc-4.0.2-8.fc4

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. rpmbuild -bb glibc.spec
2. 
3.
  

Actual Results:  GCC4 Internal Compiler Error

Expected Results:  Should have just compiled it, I suppose.

Additional info:

No additional information at this time.

Comment 1 Jakub Jelinek 2005-12-16 08:16:26 UTC
And is the problem reproducable always on the same file same error?
The compiler driver thinks it is not (tried to repeat it 3 times and it wasn't
reproducable), in which case this would be flakey hardware.

Comment 2 Jasper O. Hartline 2005-12-16 13:15:57 UTC
I was not able to reproduce this, I was pondering in fact whether or not to file
this as a bug at all. I agree, it has to be the hardware I was using.

The machine is relatively old, Dual Processor PII@300MHz, 512MB EDO SIMM RAM
3.3v,  standard peripherals.

So, no I couldn't reprodce it, if you couldn't either, then it is NOTABUG!
Thanks!


Note You need to log in before you can comment on or make changes to this bug.