Bug 175916 - pam upgrade left system-auth.rpmsave, but no new system-auth created (disables logins)
pam upgrade left system-auth.rpmsave, but no new system-auth created (disable...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 03:10 EST by Jarod Wilson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-30 12:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2005-12-16 03:10:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Upgraded pam at some point yesterday, and my existing pam system-auth file got moved to system-auth.rpmsave, but no new file was ever created. That left the system unable to authenticate any new logins.

Version-Release number of selected component (if applicable):
pam-0.80-14.1

How reproducible:
Didn't try

Steps to Reproduce:
1. Start w/a fully updated FC4
2. Install packages from the development tree (most notably, pam)
3. Try to log in
  

Actual Results:  Unable to login to system.

Expected Results:  Should be able to login to system.

Additional info:

Fixed by renaming system-auth.rpmsave to system-auth. Note that my system-auth file was modified by authconfig to include ldap authentication, so perhaps that's what triggered the .rpmsave, but something certainly went wrong w/creating a new one...
Comment 1 Tomas Mraz 2005-12-16 05:29:48 EST
That would have to be a RPM bug as system-auth is marked %config(noreplace) in
spec file so the original system-auth shouldn't be overwritten and instead of it
a system-auth.rpmnew should be created.
Comment 2 Jeff Johnson 2005-12-22 00:32:49 EST
Files with extension .rpmsave are created when the original file is not in a package.

I see no evidence that this "would have to be an RPM bug".
Comment 3 Tomas Mraz 2005-12-22 03:49:05 EST
Well the reason is that the files mentioned are in the new version of the
package so they shouldn't be removed. I don't say that it is 100% rpm bug.
Depending on the install method it can be also yum or it might be SELinux policy
bug. But it definitely isn't a bug in the PAM package.

Reporter, could you please write exact steps you have done when you were
upgrading the PAM package?
Also could you try the same steps with the newest PAM library?
And do you have SELinux on and in enforcing mode?
Comment 4 Jarod Wilson 2005-12-22 04:02:03 EST
I'd probably have to retrace my steps entirely to figure out exactly when  
things went wrong, this system was a fully updated FC4 box that I started  
doing nightly yum upgrades on. One such upgrade included the pam version 
mentioned in the initial description. No problems with the subsequent upgrade 
to pam 0.99.2.1-2 though. I'll see what I can get with another FC4 system...  
  
Ah, and SELinux is disabled.  
Comment 5 Paul Nasrat 2005-12-22 06:52:28 EST
I've done successful upgrades using anaconda to rawhide from FC4 + updates. I'll
try and reproduce here.
Comment 6 Jarod Wilson 2005-12-25 17:40:15 EST
Just tried to reproduce here. Fully updated an FC4 box, ran authconfig to enable
ldap authentication, then upgraded to pam out of current rawhide
(0.99.something), and everything worked as expected this time.

On a semi-related note, a full yum upgrade to rawhide has made the system
completely unbootable, but that's for another ticket...

Note You need to log in before you can comment on or make changes to this bug.