Bug 1759162 - Fetchmail 6.3.x versions are discontinued and no longer supported.
Summary: Fetchmail 6.3.x versions are discontinued and no longer supported.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fetchmail
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-07 14:09 UTC by Dario
Modified: 2019-10-14 15:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-09 14:35:42 UTC


Attachments (Terms of Use)

Description Dario 2019-10-07 14:09:55 UTC
Description of problem:
In my repo Fedora 20 aren't availabe the new Fetchmail version 6.4.1
The Fetchmail 6.3.x versions are discontinued and no longer supported.

Version-Release number of selected component (if applicable):
Fedora release 20 (Heisenbug)


How reproducible:
yum update fetchmail

Steps to Reproduce:
1.
2.
3.

Actual results:
yum list fetchmail

fetchmail.x86_64                                                                  6.3.26-2.fc20

Expected results:


Additional info:

Comment 1 Vitezslav Crhonek 2019-10-08 08:29:13 UTC
Hi,

Fedora 20 is EOL (end of life) since 2015-06-23.

fetchmail-6.4.1 is currently available in Fedora Rawhide and it's going to appear in Fedora 32.

Comment 2 Dario 2019-10-09 14:31:04 UTC
Thank you for the response.
I see that fetchmail-6.4.1 aren't present in repo Centos 8.
Is this a bug?
We would like use the last Fetchmail 6.4.1

Comment 3 Vitezslav Crhonek 2019-10-10 07:10:54 UTC
This is expected, because RHEL8 contains fetchmail-6.3.26. We do not plan
to update to fetchmail-6.4.1 in RHEL8 at the moment. But fetchmail-6.3.26
present in RHEL8 contains fixes backported from upstream, most importantly
SSL related, if that's your concern.

Comment 4 Dario 2019-10-10 07:23:38 UTC
We have more error connections time out or error socket 2
This problem occours some weeks
Since version 6.3 is no longer supported by I thought that might be the problem.


Log my fatchmail:
Oct  1 09:15:53 pecgate fetchmail[5365]: time expired after 300 seconds while waiting for the connection to the mail.postecert.it server.
Oct  1 09:15:53 pecgate fetchmail[5365]: Socket error during recovery from appalti@smatorino.postecert.it@mail.postecert.it
Oct  1 09:15:53 pecgate fetchmail[5365]: Query status = 2 (SOCKET)

I try increase my timeout but I have error Socket 2.

Comment 5 Vitezslav Crhonek 2019-10-14 12:50:35 UTC
I see. But that 6.3 version is no longer supported doesn't mean that it should suddenly stop working.

I've created build of 6.4 version for CentOS 8 epel, you can try whether it solves your issue:
https://copr.fedorainfracloud.org/coprs/vcrhonek/fetchmail-epel8/

Comment 6 Dario 2019-10-14 15:46:15 UTC
Thank you for the support.
I have download the last fetchmail for my Centos8
Regards.


Note You need to log in before you can comment on or make changes to this bug.