Bug 1759185 - Help for oc adm upgrade --force option does not describe new behavior
Summary: Help for oc adm upgrade --force option does not describe new behavior
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-07 14:49 UTC by Mike Fiedler
Modified: 2020-05-13 21:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:27:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 121 'None' 'closed' 'Bug 1759185: clarify upgrade''s force flag description' 2019-11-25 07:38:32 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-05-13 21:27:08 UTC

Description Mike Fiedler 2019-10-07 14:49:29 UTC
Description of problem:

With https://bugzilla.redhat.com/show_bug.cgi?id=1756454 merged oc adm upgrade --force is now used to allow upgrade when content validation fails.    The help for the --force option does not describe this behavior - the help is basically the same as the for the new --allow-upgrade-with-warnings option"

      --allow-upgrade-with-warnings=false: Upgrade even if an upgrade is in process or a cluster error is blocking the
update.

      --force=false: Upgrade even if an upgrade is in process or other error is blocking update.


Version-Release number of selected component (if applicable): 

4.2.0-0.nightly-2019-10-07-011045


How reproducible: Always

Comment 2 Mike Fiedler 2019-10-07 15:51:01 UTC
Disregard comment 1 - wrong bz.

Comment 4 zhou ying 2019-11-18 00:57:58 UTC
Confirmed with oc version, the issue has fixed:
[root@dhcp-140-138 oc-client]# oc version
Client Version: v4.3.0

[root@dhcp-140-138 oc-client]# oc adm upgrade -h
Upgrade the cluster to a newer version

......
      --force=false: Forcefully upgrade the cluster even when upgrade release image validation fails and the cluster is
reporting errors.

Comment 6 errata-xmlrpc 2020-05-13 21:27:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.