Bug 1759193 - "Installed" tab contains core system applications and allows uninstalling them
Summary: "Installed" tab contains core system applications and allows uninstalling them
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F31FinalBlocker F31FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-10-07 15:02 UTC by Daniel Rusek
Modified: 2019-10-14 11:09 UTC (History)
11 users (show)

Fixed In Version: gnome-software-3.34.1-4.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-11 23:18:21 UTC


Attachments (Terms of Use)
Installed applications (108.50 KB, image/png)
2019-10-07 15:02 UTC, Daniel Rusek
no flags Details
Installed applications 2 (113.94 KB, image/png)
2019-10-07 15:03 UTC, Daniel Rusek
no flags Details
Installed applications 3 (107.88 KB, image/png)
2019-10-07 15:04 UTC, Daniel Rusek
no flags Details
Installed tab with the new gnome-software build on Fedora 31 Beta (85.84 KB, image/png)
2019-10-10 15:41 UTC, Daniel Rusek
no flags Details
Installed tab with the new gnome-software build on Fedora Silverblue Rawhide (55.28 KB, image/png)
2019-10-10 15:42 UTC, Daniel Rusek
no flags Details
GS verbose log from Fedora 31 Beta (99.48 KB, text/plain)
2019-10-10 15:43 UTC, Daniel Rusek
no flags Details
GS verbose log from Fedora Silverblue Rawhide (46.14 KB, text/plain)
2019-10-10 15:44 UTC, Daniel Rusek
no flags Details

Description Daniel Rusek 2019-10-07 15:02:05 UTC
Created attachment 1623177 [details]
Installed applications

Description of problem:
The "Installed" tab on latest Fedora 31 Beta contains a lot of entries including system packages such as GNOME Shell, Mutter, parts of GNOME Control Center etc. and allows uninstalling them! This is a huge issue because a user can easily broke his system by uninstalling Mutter or GNOME Shell in a few clicks.

Some entries are also duplicated (displayed two or more times). There is also a "Install to Hard Drive" app displayed although the system is already installed.

See the attached screenshots.

Version-Release number of selected component (if applicable):
gnome-software-3.34.0-2.fc31.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Use latest, fully updated clean installation of Fedora 31 Beta.
2. Open GNOME Software and switch to the "Installed" tab.
3. Look at the installed applications.

Actual results:
Some core system applications are displayed and removable.

Expected results:
Core system applications are not displayed at all or displayed as not removable.

Additional info:
I have also tried reproducing this on Fedora 31 Silverblue Beta and Mutter and other system parts are not displayed there, however the duplicated entries are.

Comment 1 Daniel Rusek 2019-10-07 15:03:44 UTC
Created attachment 1623178 [details]
Installed applications 2

Comment 2 Daniel Rusek 2019-10-07 15:04:09 UTC
Created attachment 1623179 [details]
Installed applications 3

Comment 3 Daniel Rusek 2019-10-07 15:06:53 UTC
I don't remember seeing this issue ~two weeks ago, so it looks like that this regression was most likely caused by some recent update.

Comment 4 Kalev Lember 2019-10-07 15:07:42 UTC
I think this is a regression from latest appstream-glib update that added automatic desktop file parsing (https://github.com/hughsie/appstream-glib/pull/325). Richard?

Comment 5 Daniel Rusek 2019-10-08 07:46:51 UTC
Any chance this regression can be fixed before F31 is released? Would it need a freeze exception?

Comment 6 Richard Hughes 2019-10-08 11:21:32 UTC
Yes, this needs to be fixed before F31. Can someone request an exception please. I'll work on this bug this afternoon.

Comment 7 Fedora Blocker Bugs Application 2019-10-08 11:46:23 UTC
Proposed as a Freeze Exception for 31-final by Fedora user asciiwolf using the blocker tracking app because:

 The "Installed" tab in GNOME Software on latest Fedora 31 Beta contains system packages such as GNOME Shell, Mutter, parts of GNOME Control Center etc. because of a regression in appsteam-glib and allows uninstalling them. This is a huge issue because a user can easily broke their system by uninstalling Mutter, GNOME Shell or other system package in a few clicks.

Comment 8 Adam Williamson 2019-10-08 15:16:13 UTC
+1 FE for sure.

Comment 9 Richard Hughes 2019-10-08 16:17:33 UTC
There's a fix for this upstream: https://gitlab.gnome.org/GNOME/gnome-software/merge_requests/335 -- I really think this should be fixed for F31.

Comment 10 Fedora Update System 2019-10-10 08:56:31 UTC
FEDORA-2019-01e9c34ed3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-01e9c34ed3

Comment 11 Fedora Update System 2019-10-10 14:34:04 UTC
gnome-software-3.34.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-01e9c34ed3

Comment 12 Daniel Rusek 2019-10-10 15:40:05 UTC
As discussed on IRC, it seems that the fix unfortunately created another regression. There are now almost no installed rpm apps displayed on the Installed tab of GNOME Software and when I right click some installed app in Shell Overview and click "Show Details", I get either "Sorry! There are no details for that application." or a details page for a Flatpak version (Flatpaks seem to work fine) instead of the rpm one. It also seems that if the application is already installed, it cannot be found in GS anymore - I tried installing calibre, it installed fine and was displayed on the "Installed" tab, then I tried killing and restarting gnome-software; after this, calibre isn't on the Installed tab anymore and searching for "calibre" in GS finds nothing (or only the Flatpak result if I have Flathub repo added). I tried this on fully updated clean installation of Fedora 31 Beta and fully updated Fedora Silverblue Rawhide and there was the same issue with rpm apps on both of them.

I am including logs of "gnome-software --verbose --mode=installed" and screenshots from both classic Fedora 31 Beta and Fedora Silverblue Rawhide.

Comment 13 Daniel Rusek 2019-10-10 15:41:47 UTC
Created attachment 1624409 [details]
Installed tab with the new gnome-software build on Fedora 31 Beta

Comment 14 Daniel Rusek 2019-10-10 15:42:25 UTC
Created attachment 1624410 [details]
Installed tab with the new gnome-software build on Fedora Silverblue Rawhide

Comment 15 Daniel Rusek 2019-10-10 15:43:15 UTC
Created attachment 1624411 [details]
GS verbose log from Fedora 31 Beta

Comment 16 Daniel Rusek 2019-10-10 15:44:03 UTC
Created attachment 1624412 [details]
GS verbose log from Fedora Silverblue Rawhide

Comment 17 Kamil Páral 2019-10-10 17:11:32 UTC
Let's discuss this as a blocker, because both comment 0 and comment 12 might be argued to violate expected basic functionality of gnome-software (plus the specific criterion for package managers).

Comment 18 Adam Williamson 2019-10-10 17:14:32 UTC
well, #c12 is a consequence of an attempted fix for this bug, it is not the actual bug reported here. Unless we push the bad fix stable we're not going to have to worry about #c12.

I feel like calling this 'basic functionality' is a bit of a stretch too far...I mean, gnome-packagekit used to let you uninstall anything you wanted, and we shipped that for years. dnf lets you uninstall anything you want (except protected packages), and that's the criteria equivalent of Software for non-graphical installs. I think the 'release blocking' package managers for KDE and Xfce also let you uninstall any package. So, to me it would seem odd to block the release on Software behaving the same way.

Comment 19 Daniel Rusek 2019-10-10 17:24:53 UTC
As far as I know, GNOME Software is not targeted just at power users, but also at regular users that do not necessary have deeper knowledge of Linux desktop internals. Also, GNOME Software makes it easy to uninstall packages compared to gnome-packagekit where a user had to find the exact package they wanted to uninstall etc. Comparing this issue to KDE (by the way, as far as I know, Discover won't let you uninstall system packages) or Xfce package management GUIs doesn't seem fair to me since the official Fedora Workstation uses GNOME.

Comment 20 Adam Williamson 2019-10-10 17:30:53 UTC
GNOME, KDE and Xfce are the release blocking desktops for Fedora; so far as release criteria / blocker process stuff goes they're effectively equally important.

Comment 21 Ben Cotton 2019-10-10 17:44:55 UTC
+1 FE

Comment 22 Mohan Boddu 2019-10-10 17:48:58 UTC
+1 FE

Comment 23 Adam Williamson 2019-10-10 17:55:50 UTC
That's at least enough votes to accept this as an FE.

Comment 24 Fedora Update System 2019-10-11 18:59:31 UTC
FEDORA-2019-9424d60d3d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9424d60d3d

Comment 25 Fedora Update System 2019-10-11 23:18:21 UTC
gnome-software-3.34.1-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Kamil Páral 2019-10-14 08:15:38 UTC
Daniel, since the update was pushed stable, can you please file a new bug regarding the issues from comment 12 and link it here? Please re-verify whether you can reproduce it, and whenever you want to kill gnome-software to test something, please rather do a full reboot instead. Thanks.

Comment 27 Daniel Rusek 2019-10-14 09:46:14 UTC
I already tested if the new build fixes regression from the #c12, including a full reboot and was discussing this with Richard via IRC. I just tried it again and can confirm that I cannot reproduce the issue anymore.

Comment 28 Jonathan Haas 2019-10-14 09:59:03 UTC
For the record, I've also installed the latest gnome-software update (gnome-software-3.34.1-4.fc31.x86_64) and the installed applications tab looks fine, there are no system applications there and the expected apps (installed as RPM) are there and clicking on them works properly as far as I can see. So I can't reproduce comment 12, either.

Comment 29 Kamil Páral 2019-10-14 11:09:00 UTC
Awesome, thanks Daniel and Jonathan.


Note You need to log in before you can comment on or make changes to this bug.