Bug 175927 - The `raid' kickstart directive fails.
The `raid' kickstart directive fails.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 07:12 EST by QingLong
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 13:32:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QingLong 2005-12-16 07:12:12 EST
Description of problem:
The `raid' kickstart directive doesn't operate as it ought to.
Installation process always fails with the
``unable to locate raid device None for ...''

Version-Release number of selected component (if applicable):
at least fc4 and rhel3

How reproducible:
100%

Steps to Reproduce:
1. Wish to preserve some software raid array utilized
   as a filesystem which is not populated by standard installation process,
   e.g. /home/ or, say, /data/. 
2. Read kickstart manual and put into the kickstart file:
      partition raid.11 --onpart=sda1 --noformat
      partition raid.21 --onpart=sdb1 --noformat
      partition raid.31 --onpart=sdc1 --noformat
      partition raid.41 --onpart=sdd1 --noformat
      partition raid.51 --onpart=sde1 --noformat
      partition raid.61 --onpart=sdf1 --noformat
      partition raid.71 --onpart=sdg1 --noformat
      raid /storage --device=md0 --level=5 --fstype ext3 --noformat raid.11
raid.21 raid.31 raid.41 raid.51 raid.61 raid.71
   Doesn't these directives look like appropriate?
3. Start the kickstart non-interactive os installation process.
  
Actual results: The installation breaks with the message:
   ``unable to locate raid device None for /storage''


Expected results: The os installation should be successfull,
   upon which in the fstab should be present a line to mount /dev/md0 at the
/storage mountpoint.


Additional info: More than a year ago Gordon McDowall (from fasthosts.co.uk)
   had reported this problem to redhat mailing list asking for help,
   but it looks like nobody has managed to help him.
   And the bug appears to be still there.
Comment 1 Jeremy Katz 2005-12-19 13:32:06 EST
You shouldn't have to define each individual RAID member if you're using a
preexisting, just do something like

raid /storage --device=md0 --level=5 --fstype ext3 --noformat

Note You need to log in before you can comment on or make changes to this bug.