Bug 175935 - error message you cannot print in print preview and print preview has never been run
error message you cannot print in print preview and print preview has never b...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: thunderbird (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 10:12 EST by Richard Monk
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 09:30:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 348444 None None None Never

  None (edit)
Description Richard Monk 2005-12-16 10:12:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
When trying to print, the user reports they get an error: "You cannot print while in print preview".  The user has never opened print preview.  Originally, this was only after the first few prints, but now it happens on the very first print after restarting the client.

I set 
user_pref("print.whileInPrintPreview", true);

in their prefs.js, and that appeared to solve the problem, but the problem is now back.

Version-Release number of selected component (if applicable):
thunderbird-1.0.7-1.4.1

How reproducible:
Sometimes

Steps to Reproduce:
1. Open Thunderbird
2. Select Email
3. File->Print
4. Print dialog appears, hit print

Actual Results:  Pop up error: "You cannot print while in print preview"

Expected Results:  Printer prints.

Additional info:

We normally attach printing to gtklp, but I removed that to no avail.  It fails no matter what email it is.

I also noticed, previously, that a single click on 'Print' was opening multiple "preparing..." windows, and closing these did no good.

A new profile did not solve the issue.
Comment 1 Richard Monk 2005-12-16 10:37:38 EST
Hm.  It seems the mail was HTML, and there was an HTML attachment.  It was
trying to print the attachment, even though it was not displaying inline.

Turning off "Display Attachments inline" allows printing to continue normally.
Comment 2 Matěj Cepl 2007-05-17 09:30:25 EDT
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=348444) and believe that it is
more approriate to let be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.