Bug 175943 - LTC20328-Unhandled exception installing FC5
LTC20328-Unhandled exception installing FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 11:31 EST by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 12:04:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (770.69 KB, text/plain)
2005-12-16 11:34 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2005-12-16 11:31:33 EST
LTC Owner is: gjlynx@us.ibm.com
LTC Originator is: krisw@us.ibm.com


Problem description:

Tried to install FC5 from the IBM site:

 http://software.linux.ibm.com/pub/fedora/core/test/4.90/

This failed with "Unhandled exception. Installing xorg-x11-drivers - 0.99.2-
3i386. x.orgx11 driver installation package"

The system boots up with a grub > command line and a limited number of 
recognized commands.  When I reboot, it cannot read the CD ROM drive, and I 
can't reinstall.  I believe the CD ROM device driver has been deleted.

I have the anacdump.txt file which was produced by the failure if anyone wants 
it sent to them.

The build is an old FC5 build from 11/21, so the Fedora people may not want to 
look at this.

Hardware Environment
    Machine type (p650, x235, SF2, etc.):  x335

Created an attachment 
Dump from anaconda exception

We were able to use rescue to get the drive working again.  Attempted reinstall
resulted in the same failure.  I'm also getting an anaconda unhandled exception
on an x86_64 system attempting to install the 12/15 rawhide, so this seems to
be a continuing problem.

Created mirror request (id=5025)Red Hat Bugzilla

Please mirror to RedHat.
Thanks

re-assign to RedHat team for FC issue.
Comment 1 IBM Bug Proxy 2005-12-16 11:34:01 EST
Created attachment 122328 [details]
anacdump.txt
Comment 2 IBM Bug Proxy 2005-12-16 14:38:02 EST
---- Additional Comments From krisw@us.ibm.com  2005-12-16 14:35 EDT -------
Attempting to install the 12/16 rawhide on opteron (x86_64) again had an 
Unhandled exception.  It has hung trying to get the text, so I can\'t provide 
more details.  The message says to file a bug against anaconda. 
Comment 3 Jeremy Katz 2005-12-19 13:32:49 EST
It looks like you have bad media --
  <4>hdc: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
  <4>hdc: media error (bad sector): error=0x34 { AbortedCommand
LastFailedSense=0x03 }

Did you verify your media using mediacheck? 
Comment 4 IBM Bug Proxy 2005-12-20 13:58:40 EST
---- Additional Comments From krisw@us.ibm.com  2005-12-20 13:57 EDT -------
We have been experiencing a variety of Unhandled exceptions when trying to 
install i386 or x86_64 sytems from the console in our lab.  I believe the 
problem was also experienced on ppc.  We found that it seems to be related to 
the monitor used by our rack-mounted systems.  If we do \"linux askmethod vnc\" 
and install using VNC remotely, we don\'t have these exceptions.  The rack 
monitor is an IBM ThinkVision L150p 15 inch flat panel PC monitor connected 
via a Belkin KVM switch panel.  Installation doesn\'t seem to be able to handle 
this monitor when we install via boot.iso or CD install. 
Comment 5 Jeremy Katz 2005-12-22 12:04:46 EST
There are multiple read errors from your CD.  This is what's causing your
problem (that and probably hitting some of the bugs that are genuine that we
continue to fix as we're deep in our development cycle)
Comment 6 IBM Bug Proxy 2005-12-22 12:46:41 EST
---- Additional Comments From krisw@us.ibm.com  2005-12-22 12:46 EDT -------
Please check the aspect of an unrecognized monitor causing unhandled 
exceptions.  We found that CD\'s which had exceptions when installing in the lab 
via the lab monitor could be used when install was done via vnc and we went 
back to the lab to insert CD\'s when prompted.  This was experienced using 
different sets of CD\'s, not just the one used in the original report. 
Comment 7 Paul Nasrat 2005-12-22 13:09:22 EST
Please file seperate bug reports for seperate issues with the appropriate
traceback for the issue.

I can see no way that a monitor would cause the I/O Error in the traceback above. 
Comment 8 IBM Bug Proxy 2005-12-22 13:26:45 EST
---- Additional Comments From krisw@us.ibm.com  2005-12-22 13:29 EDT -------
Perhaps that particular case was the result of a bad CD, but we know from other 
cases the CD\'s were good and the difference is whether or not install is done 
on the console in the lab or remotely via VNC.  This will be a serious problem 
for us in the future. 
Comment 9 Paul Nasrat 2005-12-22 13:43:19 EST
Then please file seperate bugs with the appropriate tracebacks.  There is no
information here currently we can use to diagnose your problem.

I have performed many successful installs of rawhide - as was mentioned earlier
we are deep in our development cycle, and some days things may be broken but
currently it should be installable.  I have heard no other reports of failure
with monitor, but success with vnc so I can not hope to diagnose with out the
appropriate traceback.
Comment 10 IBM Bug Proxy 2005-12-28 14:41:36 EST
---- Additional Comments From krisw@us.ibm.com  2005-12-28 14:44 EDT -------
Currently I can\'t get far enough into install to get more info because the 
recent boot.iso\'s aren\'t letting me get as far as actually downloading files 
(ltc bug 20454 - linux askmethod fails.)  When I can retry, if I still get 
Unhandled exceptions and if more info is available I\'ll add to this bug. 
Comment 11 IBM Bug Proxy 2006-01-06 13:36:32 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|OPEN                        |REJECTED
         Resolution|                            |NOTABUG




------- Additional Comments From krisw@us.ibm.com  2006-01-06 13:35 EDT -------
Today I successfully installed the 1/5/06 x86_64 rawhide using linux askmethod 
and using the lab console - no problem.  Thanks! 

Note You need to log in before you can comment on or make changes to this bug.