Bug 175964 - Installer exception occurred during Customize Graphical Configuration
Installer exception occurred during Customize Graphical Configuration
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 14:06 EST by Vicki Tsang
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-23 11:46:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vicki Tsang 2005-12-16 14:06:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
Installing on Dolch Notepac with a customized ks file.

An unhandled exception has occurred. This is most likely a bug. Please copy the full text ofthis exception and file as detailed bug report against anaconda at http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last):
File "usr/lib//anaconda/gui.py", line 771, in nextClicked
self.setScreen()
File "usr/lib/anaconda/gui.py", line 992, in setScreen
new_screen = apply(self.currentWindow.getScreen, args)
File "/usr/lib/anaconda/iw/xconfig_gui.py", line 324, in getScreen
kdeSelected = (grpset.hdrlist.has_key('kdebase')
TypeError: 'int' object is not callable

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use modified ks.conf to set part size (on seperate CD)
2.Change to original RHEL 2.2 CD when required
3.Use disk druid. Existing partion are sda1-4
4. set sda1 to /boot (format ext3) sda2 is swap (format) and sda4 to / and format ext3. Leave sda3 as ext3 and do not format.
5. Change bootloader to LILO
6.accept all following options and install

  

Actual Results:  Above exception

Expected Results:  Install completes

Additional info:

Install on Dolch NotePAC. Does not detect monitor config.
Comment 1 Vicki Tsang 2005-12-16 14:14:44 EST
Apologies - was NOT using a different ks.conf file.
Comment 2 Chris Lumens 2007-02-23 11:46:19 EST
This is fixed in later releases of RHEL because all the code involved has been
removed.

Note You need to log in before you can comment on or make changes to this bug.