Bug 1759644 - Drag and Drop between applications is broken on Wayland
Summary: Drag and Drop between applications is broken on Wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F31FinalBlocker F31FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-10-08 17:56 UTC by Jonathan Haas
Modified: 2020-04-19 15:49 UTC (History)
20 users (show)

Fixed In Version: mutter-3.34.1-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-14 15:10:43 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME mutter issues 845 None None None 2019-10-08 17:56:55 UTC
GNOME Gitlab GNOME mutter merge_requests 848 None None None 2019-10-11 18:20:22 UTC

Description Jonathan Haas 2019-10-08 17:56:55 UTC
Description of problem:

There is a drag & drop regression in mutter 3.34, see referenced Gitlab bug.

Version-Release number of selected component (if applicable):
mutter-3.34.0-5.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
Follow the steps in Gitlab, or follow the following steps:
1. Open Gimp And Nautilus
2. Open "Open File" dialog in Gimp
3. Drag image from file dialog to Nautilus

Actual results:
File is successfully moved/copied in Xorg session, but it fails in Wayland session

Expected results:
Works in both sessions

Additional info:
After bisecting the code, Sergio Costas found that the bug was inserted in the commit 634f512b :

Nov 22, 2018 15:56:24 CET
wayland: Integrate with MetaSelection
Make MetaWaylandDataDevice use MetaSelection and MetaSelectionSource to
handle primary/clipboard/dnd.
!320 (merged)

This may be related with 1669730 but according to the Gitlab issue seems to be a new issue in Gnome 3.34.

Comment 1 Jonathan Haas 2019-10-08 19:20:23 UTC
Reason for blocker request: Drag & drop is basic functionality of the desktop, also receiving dropped files is probably basic functionality of nautilus.

Comment 2 Adam Williamson 2019-10-08 21:45:33 UTC
at least +1 FE for me.

Comment 3 Chris Murphy 2019-10-09 04:13:12 UTC
I'm inclined toward +1 blocker. I agree drag and drop in a GUI is basic functionality, and also Wayland is the default protocol/compositor being used on Workstation. And also it's a regression.

But for sure +1 FE.

Comment 4 Kamil Páral 2019-10-09 13:09:21 UTC
I can confirm the problem. Under Wayland, Nautilus doesn't accept drag&dropped files.

Comment 5 Kamil Páral 2019-10-10 16:28:01 UTC
-1 blocker +1 FE. I think that dragging files is an extremely uncommon operation, and this bug is the first time I realized that it's even possible. If somebody can demonstrate a common real-world usage, I can be convinced.

Comment 6 Kevin Fenzi 2019-10-10 17:32:32 UTC
-1 blocker, +1 FE (I am with Kamil here)

Comment 7 Mohan Boddu 2019-10-10 17:33:48 UTC
I dont use drag and drop at all now, but I remember trying it while I started playing with computers.

Based on my usage now I would say +1 FE but I can see new people (like I was) might see it as an issue.

Comment 8 Adam Williamson 2019-10-10 17:34:06 UTC
That's at least +4 FE, so marking accepted FE for now.

Comment 9 Michael Catanzaro 2019-10-10 19:09:28 UTC
This should probably be considered alongside the two clipboard FE bugs, bug #1751646 and bug #1758873, since it's going to be the same underlying clipboard manager issue for all three. (Clipboard and drag-and-drop internally both use much of the same data transfer code.)

Comment 10 raster 2019-10-12 10:44:31 UTC
I can confirm that, with the code in MASTER, the drag and drop between nemo and nautilus, and between my test app and nautilus, does work fine. Thanks!!!!!!

Comment 11 Fedora Update System 2019-10-12 16:31:22 UTC
FEDORA-2019-af6c89afe8 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-af6c89afe8

Comment 12 Fedora Update System 2019-10-13 00:56:42 UTC
gnome-shell-3.34.1-2.fc31, mutter-3.34.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-af6c89afe8

Comment 13 František Zatloukal 2019-10-13 12:57:13 UTC
gnome-shell-3.34.1-2.fc31, mutter-3.34.1-2.fc31 fixes the issue.

Comment 14 Fedora Update System 2019-10-13 16:23:31 UTC
FEDORA-2019-af6c89afe8 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-af6c89afe8

Comment 15 Fedora Update System 2019-10-13 18:35:29 UTC
gnome-shell-3.34.1-2.fc31, mutter-3.34.1-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-af6c89afe8

Comment 16 Fedora Update System 2019-10-14 15:10:43 UTC
gnome-shell-3.34.1-2.fc31, mutter-3.34.1-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 volodya 2019-12-10 21:28:30 UTC
Hi.

gnome-shell-3.34.1-4.fc31, mutter-3.34.1-12.fc31 has problem with drag & drop under Wayland. This don't work from Nautilus to Gimp, Chrome, etc.

Comment 18 Simone Marchioni 2020-01-03 11:32:31 UTC
Hi,

don't know if it's related to this bug, but drag & drop doesn't work from Nautilus to Thunderbird either.
Fedora 31 with latest updates installed as of 3/1/2020.

Relevant versions:

gnome-shell-3.34.2-1.fc31.x86_64
mutter-3.34.2-1.fc31.x86_64
thunderbird-68.3.1-1.fc31.x86_64

Try to drag a file to a Thunderbird message: the file is not being attached. In the past it worked flawlessly.

Comment 19 makal 2020-04-19 15:49:31 UTC
Hi,

Don't work between file-roller and Nautilus too.


Note You need to log in before you can comment on or make changes to this bug.