Bug 1759730 - python-pycryptodomex: build for EPEL6
Summary: python-pycryptodomex: build for EPEL6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pycryptodomex
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1761876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-08 23:17 UTC by Carl George
Modified: 2019-11-15 02:23 UTC (History)
2 users (show)

Fixed In Version: python-pycryptodomex-3.9.0-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-15 02:23:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Carl George 2019-10-08 23:17:46 UTC
Description of problem:
I'd like to use this package on RHEL6.  Please branch and build it for el6.

Additional info:
If you add me (FAS carlwgeorge) or the Python SIG as a maintainer I'd be happy to take care of this myself.

Comment 1 Paul Howarth 2019-10-09 20:02:16 UTC
I had a look at this today.

I think the EL-6 python/rpm environment is so different from everywhere else that it warrants a completely separate spec rather than trying to add support into the existing spec, which is compatible with EL-7 and Fedora.

I've managed to build a test package but had to exclude the manpage as EL-6's version of sphinx (0.6.6) is way too old to build it (e.g. it doesn't support the "man" builder, doesn't include the "mathjax" extension that the package wants).

Comment 2 Paul Howarth 2019-10-10 17:25:39 UTC
OK, here is a scratch build to try:

https://koji.fedoraproject.org/koji/taskinfo?taskID=38204612

For this build I used a pre-built manpage rather than trying to generate one during the build, which is not possible with EL-6's sphinx.

I also added "-mstackrealign" as a compiler option for the i686 build; without it, the test suite (and probably other applications) segfault. I added a comment about this in the upstream issue tracker at https://github.com/Legrandin/pycryptodome/issues/308

Comment 3 Carl George 2019-10-14 17:30:16 UTC
Paul, have you considered using python-sphinx10 on el6?

Comment 4 Mohamed El Morabity 2019-10-15 08:25:32 UTC
I've just requested an EL6 branch for this package. But I'm not interested in maitaining it. Once the branch created I'll add you as maintainer for this branch.

Comment 5 Paul Howarth 2019-10-15 09:47:14 UTC
(In reply to Carl George from comment #3)
> Paul, have you considered using python-sphinx10 on el6?

No, I haven't, as I didn't know it existed. I'll take a look later and see if it's helpful.

Comment 6 Paul Howarth 2019-10-15 13:50:06 UTC
(In reply to Paul Howarth from comment #5)
> (In reply to Carl George from comment #3)
> > Paul, have you considered using python-sphinx10 on el6?
> 
> No, I haven't, as I didn't know it existed. I'll take a look later and see
> if it's helpful.

I managed to get it to build with python-sphinx10, though it also needs python-sphinxcontrib-napoleon (Bug #1761876).

There are still a few errors but I don't think they're critical:
/builddir/build/BUILD/pycryptodome-3.9.0/lib/Crypto/PublicKey/ECC.py:docstring of Crypto.PublicKey.ECC.EccKey:5: ERROR: Unknown interpreted text role "numref".
/builddir/build/BUILD/pycryptodome-3.9.0/lib/Crypto/PublicKey/ECC.py:docstring of Crypto.PublicKey.ECC.construct:5: ERROR: Unknown interpreted text role "numref".
/builddir/build/BUILD/pycryptodome-3.9.0/lib/Crypto/PublicKey/ECC.py:docstring of Crypto.PublicKey.ECC.generate:4: ERROR: Unknown interpreted text role "numref".

I think numref was introduced in sphinx 1.3. The errors are in references to a table of supported ECC curves. I think the interested reader would be able to figure out the references.

(In reply to Mohamed El Morabity from comment #4)
> I've just requested an EL6 branch for this package. But I'm not interested
> in maitaining it. Once the branch created I'll add you as maintainer for
> this branch.

Can you add me (FAS: pghmcfc) too please?

Comment 7 Paul Howarth 2019-10-30 15:14:41 UTC
OK, it's ready to build now.

Comment 8 Fedora Update System 2019-10-30 15:33:31 UTC
FEDORA-EPEL-2019-07fec2dd92 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-07fec2dd92

Comment 9 Fedora Update System 2019-10-31 01:20:58 UTC
python-pycryptodomex-3.9.0-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-07fec2dd92

Comment 10 Fedora Update System 2019-11-15 02:23:39 UTC
python-pycryptodomex-3.9.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.