Bug 175983 - [RHEL4] Meeting invitation w/acceptance is added to calendar, but the acceptor shows up as "Needs Action", instead of "Accepted"
[RHEL4] Meeting invitation w/acceptance is added to calendar, but the accepto...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 16:56 EST by Suzanne Hillman
Modified: 2008-02-03 11:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 11:28:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2005-12-16 16:56:48 EST
Description of problem:
Meeting invitation w/acceptance is added to calendar, but the acceptor shows up
as "Needs Action", instead of "Accepted". The person who scheduled the
appointment also doesn't have the acceptor changed to "Accepted", even though
the mail arrived and update was selected.

Version-Release number of selected component (if applicable):
evolution-2.0.2-25

How reproducible:
Always. At least, always with this machine.

Steps to Reproduce:
1. Schedule a meeting on another machine, as a different user. Add the testing
account to the meeting list, as required. Agree to the sending mail to let them
know dialog.
2. Receive the message as the tester and invitee, and accept with sending an
RSVP back. The new meeting will show up in your calendar, but you will still
show as 'Needs Action'. 
3. The inviter will get the mail saying you accepted, and will ask it to update
their calendar, but you will still show up as 'Needs Action'.
  
I have no idea if this is a regression, as it was not until this run through of
U3 that I was able to test this portion of things effectively. I believe that it
did work fine in RHEL3U7, however.
Comment 1 Suzanne Hillman 2005-12-16 17:15:36 EST
Ok, _this_ is weird.

I just noticed that the meeting acceptances were showing up as coming from the
organizer, not the invitee. And... while it's true that I have two accounts set
up on the invitee's side with the organizer's name, both are disabled and the
invitee's name is the default one.

I'm going to check if completely removing the organizer's accounts from evo's
mail makes things any less confused, although the fact that they are disabled
makes this all very strange.
Comment 2 Suzanne Hillman 2005-12-16 17:22:46 EST
Hmm. Ok, this was either because of the above, or because I hadn't selected
someone from my contacts in order to invite them, I just typed in enough of the
address to be able to send mail. (eg, I typed 'zebra', rather than taking the
address and adding to my address book, then adding an invitee by using the
address book. This resulted in, once I took both disabled gazelles from the
account list on zebra's side, gazelle's side saying the email reply came from
'An unknown person')

If Evo can send mail, why would it get confused about who sent the reply?

*baffled*

This is almost certainly not a regression, although it _is_ utterly strange. Not
necessarily because I had the same account name as some of the disabled accounts
on the other end, but because it seems to not cope well with people invited to
meetings who are not added from the contact list.
Comment 3 Suzanne Hillman 2005-12-19 13:50:37 EST
Changing to note x86_64 (specifically, a viper).
Comment 4 Suzanne Hillman 2006-01-25 16:46:25 EST
Interestingly, this behavior repeated yesterday with a i386, but worked as I'd
have expected today on a x86_64 (with the most recent beta). Confused... not
sure what I did differently. I... _think_ the one where it worked is the only
case where I'd not ever set up an account as more than one person (ie, the two
test accounts are zebra and gazelle that I tend to use for this, and the test
machine has only ever been zebra - although both IMAP and POP - and never gazelle).
Comment 5 Matthew Barnes 2008-02-03 11:28:46 EST
Evolution 2.0.2 is only being updated for security issues.  Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.