Bug 1759934 - python-django-helpdesk (Build)Requires python3dist(django) < 3
Summary: python-django-helpdesk (Build)Requires python3dist(django) < 3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-django-helpdesk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luis Bazan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS F32FailsToInstall DJANGO3
TreeView+ depends on / blocked
 
Reported: 2019-10-09 12:52 UTC by Miro Hrončok
Modified: 2020-01-12 01:41 UTC (History)
3 users (show)

Fixed In Version: python-django-helpdesk-0.2.19-1.fc30 python-django-helpdesk-0.2.19-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-12 01:14:53 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-10-09 12:52:23 UTC
Description of problem:
python-django-helpdesk Requires python3.8dist(django) < 3, but we have updated Django to 3.

See https://fedoraproject.org/wiki/Changes/Django3

Version-Release number of selected component (if applicable):
python-django-helpdesk-0.2.16-4.fc32
python3-django-helpdesk-0.2.16-4.fc32

How reproducible:
$ repoquery --repo=rawhide --requires python3-django-helpdesk | grep django
python3.8dist(django) < 3
python3.8dist(django) >= 1.11
python3.8dist(django-bootstrap-form) < 4
python3.8dist(django-bootstrap-form) >= 3.3
python3.8dist(django-markdown-deux)
python3dist(django) < 3
python3dist(django) >= 1.11

$ repoquery --repo=rawhide-source --requires python-django-helpdesk | grep django
python3dist(django) < 3
python3dist(django) >= 1.11



Please update to a version that supports Django 3. If there is no such version, please bring this upstream.

Note that the installation failure is now shadowed by this:
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.8dist(django-markdown-deux) needed by python3-django-helpdesk-0.2.16-4.fc32.noarch
  - nothing provides python3.8dist(django-bootstrap-form) >= 3.3 needed by python3-django-helpdesk-0.2.16-4.fc32.noarch
  - nothing provides python3.8dist(django-bootstrap-form) < 4 needed by python3-django-helpdesk-0.2.16-4.fc32.noarch

Comment 1 Fedora Update System 2019-12-27 16:08:14 UTC
FEDORA-2019-4ff5b3ca4b has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ff5b3ca4b

Comment 2 Fedora Update System 2019-12-27 16:15:20 UTC
FEDORA-2019-413fb4b0d6 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-413fb4b0d6

Comment 3 Fedora Update System 2019-12-27 16:18:27 UTC
FEDORA-2019-a210dbfb56 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a210dbfb56

Comment 4 Fedora Update System 2020-01-04 21:17:45 UTC
python-django-helpdesk-0.2.19-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a210dbfb56

Comment 5 Fedora Update System 2020-01-04 22:23:25 UTC
python-django-helpdesk-0.2.19-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-413fb4b0d6

Comment 6 Fedora Update System 2020-01-12 01:14:53 UTC
python-django-helpdesk-0.2.19-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-01-12 01:41:48 UTC
python-django-helpdesk-0.2.19-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.