Bug 1759945 - Incorrect cluster memory and disk usage displayed in openshift dashboard.
Summary: Incorrect cluster memory and disk usage displayed in openshift dashboard.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: Paul Gier
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1774009 (view as bug list)
Depends On:
Blocks: 1754459 1774653
TreeView+ depends on / blocked
 
Reported: 2019-10-09 13:19 UTC by Paul Gier
Modified: 2020-05-13 21:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1774653 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:27:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2971 'None' closed Bug 1759945: update query for memory utilitzation 2020-06-10 14:59:58 UTC
Red Hat Bugzilla 1759880 'medium' 'VERIFIED' 'update rules in cluster-monitoring-operator to reflect chages to container and pod metric labels' 2019-12-02 04:32:12 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:07:03 UTC

Description Paul Gier 2019-10-09 13:19:38 UTC
The openshift dashboard is displaying incorrect values for current memory and disk usage (and probably same issue for CPU as well).  For example, the current memory status is coming from:
(sum(kube_node_status_capacity_memory_bytes) - sum(kube_node_status_allocatable_memory_bytes))[60m:5m]

This value is never going to change over the life of the cluster because the allocatable memory is the total memory that can be used for pods.  It is not the amount of memory currently being used for running pods.

https://kubernetes.io/docs/tasks/administer-cluster/reserve-compute-resources/

The fix for this is to either use data coming directly from the nodes (cluster:memory_usage_bytes:sum), or try to calculate the amount of memory currently being used maybe by adding up the container memory usage totals.

Comment 2 Viacheslav 2019-10-25 15:44:19 UTC
Was checked on 4.3.0-0.nightly-2019-10-25-015726

Comment 3 Viacheslav 2019-10-28 07:16:18 UTC
Fixed.

Comment 4 Samuel Padgett 2019-11-20 15:54:45 UTC
*** Bug 1774009 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-05-13 21:27:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.