Bug 1759965 - GCP backend for api server has incorrect ranges allowed for heath checks
Summary: GCP backend for api server has incorrect ranges allowed for heath checks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.3.0
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks: 1759966
TreeView+ depends on / blocked
 
Reported: 2019-10-09 14:07 UTC by Abhinav Dahiya
Modified: 2020-05-13 21:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1759966 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:27:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2480 None closed Bug 1759965: data/gcp/network/firewall.tf: allow complete health check range for ILBs and NLBs 2020-04-28 08:39:21 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:07:03 UTC

Description Abhinav Dahiya 2019-10-09 14:07:35 UTC
Description of problem:

Based on https://cloud.google.com/load-balancing/docs/health-checks#fw-rule the ranges that should be allowed are `"35.191.0.0/16", "209.85.152.0/22", "209.85.204.0/22"`

But gcp firewall rule only allows `"35.191.0.0/16", "130.211.0.0/22"`

This causes health checks to api server fail when the source IPs is from `"209.85.152.0/22" or "209.85.204.0/22"``


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create cluster on GCP
2. Look at the firewall rule for the health checks


Actual results:
Health checks fail due to firewall rules.

Expected results:
Correct ranges are allowed

Additional info:

Comment 2 Johnny Liu 2019-10-16 08:52:55 UTC
Verified this bug with 4.3.0-0.nightly-2019-10-16-010826, and PASS.


1. Trigger ipi install on gcp
2. Check firewall - jialiu-lc5zf-health-checks

Source filters
IP ranges
209.85.204.0/22
209.85.152.0/22
130.211.0.0/22
35.191.0.0/16

Comment 4 errata-xmlrpc 2020-05-13 21:27:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.