Bug 1759971 - Kuryr - occasional "BadRequest: Invalid input for operation: Non unique UUID for subport" when namespace gets deleted
Summary: Kuryr - occasional "BadRequest: Invalid input for operation: Non unique UUID ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Michał Dulko
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On:
Blocks: 1759973
TreeView+ depends on / blocked
 
Reported: 2019-10-09 14:23 UTC by Michał Dulko
Modified: 2020-05-13 21:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1759973 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:27:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 55 0 None None None 2019-10-09 14:29:26 UTC
Launchpad 1847287 0 None None None 2019-10-09 14:38:04 UTC
OpenStack gerrit 687331 0 None None None 2019-10-09 14:34:37 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:07:03 UTC

Description Michał Dulko 2019-10-09 14:23:06 UTC
Description of problem:
This traceback can be seen in kuryr-controller when namespace gets deleted:

2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool [-] Error removing subports from trunk: f392a842-87c2-4db0-a261-f6084bd7f0ef: BadRequest: Invalid input for operation: Non unique UUID
 for subport: '3505b133-83f6-407b-a54a-4557dd3934cd'.
Neutron server returns request_ids: ['req-fcf04b5f-872e-4c1f-bb71-2c16cc5eb188']
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool Traceback (most recent call last):
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/drivers/vif_pool.py", line 984, in delete_network_pools
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool self._drv_vif._remove_subports(neutron, trunk_id, ports_id)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/drivers/nested_vlan_vif.py", line 225, in _remove_subports
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool {'sub_ports': subports_body})
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 2136, in trunk_remove_subports
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool return self.put(self.subports_remove_path % (trunk), body=body)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 363, in put
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool headers=headers, params=params)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 331, in retry_request
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool headers=headers, params=params)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 294, in do_request
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool self._handle_fault_response(status_code, replybody, resp)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 269, in _handle_fault_response
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool exception_handler_v20(status_code, error_body)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 93, in exception_handler_v20
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool request_ids=request_ids)
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool BadRequest: Invalid input for operation: Non unique UUID for subport: '3505b133-83f6-407b-a54a-4557dd3934cd'.
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool Neutron server returns request_ids: ['req-fcf04b5f-872e-4c1f-bb71-2c16cc5eb188']
2019-10-08 10:58:25.306 1 ERROR kuryr_kubernetes.controller.drivers.vif_pool

Version-Release number of selected component (if applicable):
4.2

How reproducible:
Occasional

Steps to Reproduce:
1. Run openshfit-tests suite

Actual results:
From time to time you'll see that error in the logs

Expected results:
No error

Additional info:

Comment 2 Jon Uriarte 2019-10-18 08:51:07 UTC
Verified on OCP 4.3.0-0.nightly-2019-10-17-061631 build on top of OSP 13 2019-10-01.1 puddle.

release image: registry.svc.ci.openshift.org/ocp/release@sha256:2cafe25ec1ed2dfdec361cde13b4461d2a30194d0b41fbd1c6d3fad5ab34ca05

Could not find the traceback described in the BZ ("BadRequest: Invalid input for operation: Non unique UUID") in the kuryr-controller
logs after running K8s NP upstream tests.

Comment 4 errata-xmlrpc 2020-05-13 21:27:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.