Bug 176000 - mahjongg doesn't start because its setuid root
mahjongg doesn't start because its setuid root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 23:48 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-16 00:25:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-12-16 23:48:41 EST
Description of problem:
>mahjongg

(mahjongg:4715): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html


Version-Release number of selected component (if applicable):
gnome-games-2.13.3-1

Expected results:
mahjongg should probably not be setuid root any longer since gtk seems to no
longer allow that.


-jef
Comment 1 Jef Spaleta 2005-12-16 23:53:51 EST
This affects several games in gnome-games
mahjongg
gnomines
same-gnome
glines

all have the same error about setuid

without mahjongg or gnomines working how am I suppose to get through my workday?

-jef
Comment 2 Warren Togami 2005-12-16 23:55:36 EST
Security implications, advice would be appreciated.

WHY would these things be setuid?
Comment 3 Bill Nottingham 2005-12-17 00:13:10 EST
They're setgid games, for writing score files. Have been that way for a while...
Comment 4 Jef Spaleta 2005-12-17 00:36:26 EST
appearently gtk no longer likey the setgid
Comment 5 Mark J. Cox (Product Security) 2005-12-19 05:53:37 EST
See http://bugzilla.ubuntu.com/show_bug.cgi?id=19668#c8 for an explanation of
why these games have started being blocked (due to an upstream change in the games).
Comment 6 Mark J. Cox (Product Security) 2005-12-19 05:56:13 EST
Also http://lwn.net/Articles/156888/ which documents the new scores API behaviour

Note You need to log in before you can comment on or make changes to this bug.