This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 176001 - password not accepted in xscreensaver after update
password not accepted in xscreensaver after update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 23:51 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-07 08:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Authentication info for failure with pam module (13.91 KB, text/plain)
2005-12-16 23:53 EST, Jim Cornette
no flags Details
One of four logs for gdm (1.94 KB, text/plain)
2005-12-16 23:55 EST, Jim Cornette
no flags Details
avc: denied errors (22.90 KB, text/plain)
2005-12-16 23:58 EST, Jim Cornette
no flags Details
this is a list of packages updated on system 12/16/205 (13.49 KB, text/plain)
2005-12-17 00:03 EST, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2005-12-16 23:51:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
After starting yum to update my system via a root gnome-terminal, I could not unlock xscreensaver using my known password. I could however change to a virtual terminal and login to a terminal. After logging in to a terminal, I could kill xscreensaver as a regular user. After switching back to the console, I found that typing text in my root gnome-terminal would fail. I could drag the window of te terminal, highlight text but not type anything within the terminal.
I then pressed ctl-alt-delete to exit the session of X. When the session restarted gdm could not authenticate user.
I therefore logged into another virtual terminal as root. I then ran 'setenforce 0'.
After that, I changed to the console and killed X again with ctl-alt-backspace. Authentication still failed. with the error message repeating when I clicked OK and ctl-alt-backspace respawning gdm, I switched to a regular user account and started X using 'startx -- :8'
The startx login was succesful and the system was in a usable state with the new X session with 'setenforce 0' still set.
After closing down critical tasks, I rebooted the system and appended 'autorelabel' to the grub loader. The system now seems to be acting normally.
Switching to to my virtual terminal for

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.1.6-4 xscreensaver-base-4.22-21 pam-0.99.2.1-1

How reproducible:
Didn't try

Steps to Reproduce:

1. start yum to update system via script that updates what does not have dep problems. Let yum run unattended.
2. lock screensaver and go to work
3. get home (over 8 hours), screensavers cycling
4. Press key, password box appears.
5. Type password, xscreensaver login fails
6. Switch to virtual terminal, log in as regular user
7 killall -9 xscreensaver
8. switch back to (X) console
9. enter open gnome-termnal by clicking with mouse
10. try typing text, no echo from terminal
11 . ctl-alt-backspace to restart X
12. gdm authentication fails, click on dialog box
13. log into another virtual terminal and issue 'setenforce 0'
14: switch to console and ctl-alt-backspace gdm again
15. get error dialog stating authentication, click on dialog box OK button, which repeatadly respawns on OK click
16. switch to normal user and run startx -- :8 to get a GUI session active
  

Actual Results:  Whenever I typed in my password to unlock xscreensaver, authentication would fail.
When xscreensaver was killed, a GUI was present on screen 0, but no text could be typed in the open root gnome-terminal.
Launching from a normal user an X session on screen 8 via startx -- :8 worked successfully. gdm was still present with error dialog box on display 0.
rebooting and relabeling system seemed to correct the problem.

Expected Results:  A system updated with packages that met dep requirements.
The ability to unlock xscreensaver via the login box w/ flame.
See normal activity on the computer.

Additional info:

The secure log seems to have details related to the authentication problem. I will submit logs with seemingly related failure logging.
Comment 1 Jim Cornette 2005-12-16 23:53:25 EST
Created attachment 122360 [details]
Authentication info for failure with pam module
Comment 2 Jim Cornette 2005-12-16 23:55:25 EST
Created attachment 122361 [details]
One of four logs for gdm

This log had failures recorded, the other logs fo gdm seeed normal and are not
submitted.
Comment 3 Jim Cornette 2005-12-16 23:58:25 EST
Created attachment 122362 [details]
avc: denied errors

These failures encompass several days with errors. Relabeling has been ran
sveeral times for other failures. These excerpts are included from the messages
log.
Comment 4 Jim Cornette 2005-12-17 00:03:34 EST
Created attachment 122363 [details]
this is a list of packages updated on system 12/16/205

These were updated via the script.
Comment 5 Daniel Walsh 2005-12-17 00:05:54 EST
Why is this reported as an SELinux bug?

I am changing it to xscreensaver.

The avc messages you are reporting came from a bad policy file that went out
Thursday night.  If you grab tonights policy out of rawhide it should be fixed.
 I do not thing the screensaver problem is related to selinux.

You can grab updated packages now at 

ftp://people.redhat.com/dwalsh/SELinux/Fedora
Comment 6 Jim Cornette 2005-12-17 09:21:03 EST
This seems to be related to the pam upgrade. Either
https://www.redhat.com/archives/fedora-test-list/2005-December/msg00479.html
or similar problems.

With the authentication problems and denials, I picked SELinux as the culpret.

Changing this problem to pam since gdm, xscreensaver and other items related to
pam seemed to be effected ,rebooting was probably needed to restart long running
services as mentioned in link to posting.
Comment 7 Jim Cornette 2005-12-17 10:36:02 EST
Actually this posting seems closer to the problem and resolution,

https://www.redhat.com/archives/fedora-test-list/2005-December/msg00474.html
Comment 8 Jim Cornette 2006-01-07 08:06:32 EST
Bug was related to problem with pam which was fixed. Cleaning up open bugs.
Closing as fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.